Cannot Connect to WiFi - Initial Set Up

Hi, I just received my 2 RS+ units, and I cannot connect them to my local wifi for the firmware update. For both units, I can connect to their WiFi hotspots (although it seems to give me an incorrect password message if I try to connect to quickly). Then, I enter my home WiFi network name and password, click save, then click the network and click Connect. My phone reverts back to the same home WiFi network, but the RS+ shortly returns to hotspot mode and never connects to the home WiFi. I have tried numerous times, with both a 2.4ghz and a 5ghz network and on both RS+ devices.

Please help!

Jon, if you can, set your phone up as an open hotspot, then try connecting the Reach RS to your your phone’s hotspot. You would need to use another device (ie tablet, ipad, etc) to control the Reach RS. But see if that will let you get the Reach RS connected to the internet so you can update.

Are you sure you are selecting the correct Security type? If you have not tried WPA2-PSK, then I would try that as well for your regular home wifi network. Hope this helps.

1 Like

I can’t set it up as a hotspot, I don’t have that on my Verizon account.

I have selected the correct security, although I did notice that on both the app and the web interface, even if I select WPA2, when I click to connect in the Reach App/web interface, it has regular WPA listed as the selected type.

So I took them to a friends house and was able to connect to their WiFi and update both devices. Still can’t connect to my WiFi networks even after the firmware update…any ideas on what I might need to change?

In my experiences, these things make the wifi not connect:

  • Channels 11-13
  • MiMo technology
  • 5 ghz / autoswitching 2.4/5 ghz
  • More than 1 accesspoint stored in RS+
  • WPA2-PSK only. My router had to be set to WPA/WPA2 mode for it work.

Thanks for the advice, please see below:

  • On Channel 10
  • No MiMo
  • I do have 5ghz and 2.4ghz but they are different SSIDs and passwords, so no autoswitching
  • I have cleared out any other access points
  • I did have my router set to WPA2 only. I tried switching it to combo WPA/WPA2 mode, re-did all the Reach connections, but still no luck getting connected. The Reach still goes back to hotspot mode pretty quickly after trying to connect to the WiFi.
1 Like

Hi @jaltschuld,

Which ReachView version is installed on your device now? In v2.15.3 dev update, the Wi-Fi connection timeout was increased. It should help with connection to your home Wi-Fi.

1 Like

Hi Tatiana,

I do not have the Dev Version, I have 2.14.x (don’t remember the exact number but remember it was the latest update without turning on dev updates).


You can subscribe to dev channel in ReachView Settings tab. I’d recommend you to update Reach to dev version, after that Reach should connect to your Wi-Fi network just fine.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.