Cannot connect to the wifi with rpi3 and navio2

Wifi connectivity issues with the navio2 board.


Please, specify as more details as possible.

Hi !

I have a navio2 with a pi3. I have tried to setup a static ip as on the navio2 by modifying the /boot/wpa_supplicant.conf file to the ssid of the static ip in the wifi router as suggested in the documentation.

The issues I am facing are follows:

  1. The method as suggested in the guide does not work. I have tried several times (replaced the pi3 + flashed the image on new cards + replaced the navio2 )

  2. Why is there an intwifi0 instead of the default wlan0 as as pi3 do?
    I came across this as I searched online for possible solutions to the assignment of static ip on rpi3 one of them suggested modifying the /etc/network/interfaces config and disabling dhcpcd service. This method worked for static ip assignment using ethernet. But the wifi access method still fails for ping and ssh ( ssh server on the pi3 was enabled when I tried this)

  3. The documentation does not mention any alternative methods for accessing the navio2 except wifi and using tmux is really not intuitive with US keyboard layout.

Please advise on the following:

  1. How to get the intwifi0 method working for ssh into the navio2 ?
  2. If you could provide alternative strategies for using wifi that would be terrific!!
  3. How are the ros messages been transmitted (over wifi or what other method of communication is used) with the ground control station ?

Thanks in advance

It was needed in order to support Wi-Fi broadcast feature.

Could you please share the contents of /boot/wpa_supplicant.conf? You can try populating the file like this when connected to a Raspberry Pi (either via Ethernet or HDMI).

Could you please elaborate? The default layout is en_GB.UTF8 (the same as from Raspberry Pi Foundation). In order to generate a locale you can either use raspi-config or just uncomment an appropriate line in /etc/locale.gen and then run sudo locale-gen and you’re good to go.

Here’s an overview that explains how everything’s set up. The gist being: mavros connects over a local UDP endpoint to ArduPilot and then to a endpoint on a GCS specified in a _gcs_url.

There’s a project called create_ap that I find quite useful from time to time. It creates a Wi-Fi hotspot.

Hope it helps.

I am not sure if this helps, but in order to connect to Navio2/Rpi3 image to my home network, I do two things (after raspi-config change localisation:wifi to home country, CA, for me):

(1) As suggested, I edit /boot/wpa_supplicant.conf to add the SSID=“xxxxx” and PSK=“xxxxx” of my wifi network, then

(2) I edit /etc/wpa_supplicant/wpa_supplicant.conf and add the same information as above.


This works every time for me.



Thanks for the clarification

The contents od /boot/wpa_supplicant.conf file are as follows
> country=GB

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

I will try that and get back to you.

Thanks for the info. I will check it out.

I will check that out.

Please let me know if the wpa_supplicant file is written correctly.


It looks as if you didn’t specify your password after all at all.

I’m linking this once more. So basically you’ll need this:

sudo bash -c "wpa_passphrase NAMEOFWIFI yourpassword >> /boot/wpa_supplicant.conf

I don’t have a password. Its not WPA secured. Do I need to have the router to be secured for this to work?

Okay, I haven’t taken this opportunity into account.

In that case you need this:


Is the network 5GHz or 2.4GHz? If the former, the built-in Raspberry Pi 3’s Wi-Fi will not work.

I will try this

And for the wifi its on 2.4GHz

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.