Cannot connect to Massachusetts CORS - Recv error (114)

I am relatively new to Reach RS and Reach GPS units with ReachView v2.9.0-r0. I am trying to set up both units as rovers using NTRIP corrections from Massachusetts CORS RTK data using the product information here: http://64.28.83.186/spiderweb/frmIndex.aspx

The following image shows the RTK settings for the Reach GPS (I am using only GPS and GLONASS):

In the NTRIP option of the Correction Input tab I first add the IP address provided by the CORS service and the port number. Reachview then automatically pulls the mountpoints available and I choose the closest one to Boston with RTCM3 format. However, I keep seeing the Recv Error (114). Please see the attached image below.

Next, I add the username and password and when I press the apply button, Reachview shows ‘New settings were not applied’. Please see the attached image below.

I have tried this with other ports and corresponding mountpoints with clear sky view and receive exactly the same errors. There is not much documentation available on the error codes and only one similar issue in this forum.

Do you know what “no network correction” means? Its stated here

Well my bad! I should have taken screenshots with the mountpoints which provide network corrections (rookie mistake). I tried the same with the following settings:

Address: 64.28.83.185
Port: 10000
Mountpoint: RTCM3_MAX (which has network correction and GLONASS capable)
Message type: RTCM3 (product page says MAX RTCM 3.x (Extended;1015;1016))

along with the username and password. I receive the same error. I understand that it could be due to a problem with the service provider. However, it would be great to know what the Recv Error (114) means and why I cannot apply the settings with my username and password so that I can track down the issue and possibly resolve it with MaCORS.

Sorry for being a newbie to this awesomely designed product!

Did you enable VRS? And a screenshot of input config if possible

Hi @TB_RTK,

Sorry for the delayed response. Yes I did enable the VRS. Following are a few screenshots from the webapp.

Seems like its picky about the credentials. Did you select mountpoin from dropdown menu. Try fill in user and pass before selecting mountpoint

Hello,

Thanks for detailed info. I tried your credentials(with a random password of course) and I seem to get the correct unauthorized error.

The error you see is just an error of ReachView trying to connect and getting the connection request turned down.

Could provide me with the full credentials, so I can test this out? NTRIP providers always behave differently, so problems like this might occur.

Hi @TB_RTK and @egor.fedorov,

Thanks for your quick response guys! This is turning out to be a great learning experience!

Yeah I tried multiple orders of filling in the credentials with the same results. Also, I was wondering if there is another NTRIP client I could use to check if I can connect to the MaCORS NTRIP server? I tried https://github.com/nunojpg/ntripclient but it did not work either. Not sure if it will work at all since it is a pretty old implementation.

@egor.fedorov: Can I send you a private message or email the credentials?

Thanks again :slightly_smiling_face:

@TB_RTK Thanks for the awesome suggestion of removing the ‘#’ from my CORS account password. I guess this is when experience matters.

Following is a link to a video showing Reach RS set up as a rover in kinematic mode, connected to my phone’s hotspot and receiving corrections from Massachusetts CORS network:

Will try to get better fix solutions in an open field soon and report results! Thanks all!

2 Likes

This topic was automatically closed after 100 days. New replies are no longer allowed.