Cannot connect the wifi with the new release image

Hello I’m using the new navio2 release RPI image.
I also saw the article ‘Can’t connect to the network’, but don’t understand the solution.
( It does not specify how to reconfigure or something)

I’ve changed the /boot/wpa_supplicant.conf file. i didn’t make typo something like WPA-PSK.

network = {

And still the wifi does not work. What should i do make it work properly?
And I think you need to debug and re-release the image on the website, because there are bugs like this.


Oh i’m sorry, there was some bug, which i made.
I was trying to use wifi-direct on the Navio RPI, and in the middle of doing that, there were some problems.

In fact, i’m struggling to make the wifi-direct work, because of the changed network interface name.
I will post another issue later related to this.

Thanks. :slight_smile:

As you can see, i thought it’s working but actually it’s not working with wifi.
It’s same problem in another post, which i mentioned at the first writing above. ‘Can’t connect to the network’.
At the post, the part of solution related to dhcpcd is mentioned, but not detailed.

What should i do make it work?

For more information, the IP address is assigned with the intwifi0,
but actually the router does not recognize it, and the ssh does not work with wifi.
(I think the network is not working actually)

same problem with USB wifi dongle. DHCP gets an address, can ping it, but cannot actually use it. Configured SSH to bind to all IP’s and disabled intwifi0.

am having same issue, cant get the built-in wifi of the RPi3 to work…come on there has to be a fix for this

i just figured it out, went ahead and loaded the GUI for it, problem solved…steps below

Alternatively you could try

sudo wpa_gui

(sudo apt-get install wpagui, if not present on your system),

Yeah, you did with GUI wifi connection, right?
It’s nice detour, Thanks :slight_smile:

However, i think we need the fundamental solution for this.
The released image does not work with the basic wifi, so it’s kind of critical problem.

I hope this would be solved soon.

Having the same wifi issue with this image release.

Same issue here, been bashing my head on the keyboard :scream:
I noticed when I took a peep @ /etc/network/interfaces there were 3 references to
/etc/wpa_supplicant/wpa_supplicant.conf in there.

I was labouring under the impression that the correct file for this was located @
/boot/wpa_supplicant.conf This the file we are told to add our network details to.
Can someone with greater knowledge of Linux guide me out of the fog.


I am experiencing the same issue.
Below you will find out how my configuration is:

  1. /etc/wpa_supplicant/wpa_supplicant.conf: It is mirroring the same configuration as /boot/wpa_supplicant.conf

  2. /boot/wpa_supplicant.conf: I added my network following the steps according to the documentation

  3. /etc/network/interfaces: Here I have the configuration for intwifi0 and it is pointing /etc/wpa_supplicant/wpa_supplicant.conf

  4. ifconfig: It is not recognizing intwifi0. I am only seeing lo and eth0

Hello, Esteban!

Could you please reflash your SD card in case it hadn’t been done before to eliminate the risk of misconfiguration.

Hi George,

I have reflasked my SD card for around 4 times and the wifi issue has been always experienced.

I am using Etcher (v1.0.0-rc.5) on Mac Os Sierra (10.12) to reflash my SD Card and the image that I am using is the release 20170323 (which is the latest stable).

I will try to reflask one more time and I will share my configuration.



Hey George,

I already reflashed my SD Card and I tried to configure the wifi following the steps as per the documentation.

The wifi is not working yet.

Below you can see how my configuration at this moment:

  1. I am using macOs Sierra 10.12 to access an RPI3 Model B by Zeroconf (ssh)

  2. The image that I am using is the latest release (emlid-raspbian-20170323.img.xz) and it is being flashed to the SD Card using Etcher (v1.0.0-rc.5)

  3. I configured the wifi access typing
    sudo bash -c 'wpa_passphrase EM 123Queso >> /boot/wpa_supplicant.conf'

  4. This screenshot shows what is in /boot/wpa_supplicant.conf

  5. I removed the country code

  6. I rebooted the RPI

  7. This screenshot shows my network configuration (ifconfig)

  8. This screenshot shows my wireless configuration (iwconfig)

  9. This screenshot shows what is in /etc/network/interfaces

  10. This screenshot shows what is in /etc/wpa_supplicant/wpa_supplicant.conf

Please let me know if I am missing something.

Thanks for your support,


Are you sure you’re using Raspberry Pi 3? Is there any other Raspberry Pi around you can try out?

Yes, I am using a Raspberry Pi 3 Model B V1.2, I bought it on Amazon…this is the one that I am using:

At this moment I don’t have any other Raspberry Pi, but I will try to find out one for tomorrow.

It’d be great. This will eliminate the hardware problems. I mean, this is the image I use personally and reflash SD cards every day and it works out of the box.

I just ordered a brand new RPI3 and a wifi dongle to test if it is something related to the built-in wifi.
They will be delivered tomorrow. I will let know my findings as soon as I can perform my test.

if you want to use wifi broadcaster make sure it is compatible here or here
i do believe you won’t need the wifi dongle otherwise…also some of them are capeable of long range transmission!

Hi George,
You were right, it was a hardware issue, I tried the same image in a different RPI3 and it worked.


1 Like