Cannot calibrate accelerometer on Navio2

Everything is functioning normally with my setup but I’m completely stuck trying to calibrate the accelerometer on my Navio2/Pi 3 combo. I have tried via telemetry radios and also WiFi and in both cases the calibration eventually times out or stops responding, sometimes after the first step, sometimes after 2 or 3 have been completed.

Only mission planner on win 10 will even let me start calibration, APM Planner 2 on mac/win doesn’t do anything.

I know this is a common issue but none of the suggested fixed I’ve found seem to help.

Did you try Mission Planner 1.3.41 for windows? try that first…
usually accelerometer calibration fails if you take too long to accept next point or wobble too much when accepting a point;

Yes, have tried using Mission Planner 1.3.41 on Windows, and am only taking a second or 2 to do each point before clicking continue. There is no/minimal wobbling whilst the board is on each side.

Never had this issue with previous hardware (Pixhawk) - there seems to be something odd going on…

for wobbling: best practice is always to not touch navio (or your drone if possible) when accepting;
what do you mean with “stop responding”? do you have to restart MP?

I start the acc calibration, via the wizard in mission planner and there is a long delay before it reacts and asks me to place the board level and press any key. I place the board level and hit continues and there is an even longer delay before it asks me to place the board on it’s left side. I balance the board on it’s side and remove my hands, careful not to touch anything and hit continue. Even longer delay before eventually it asks me to place board on it’s right side… at this point the calibration wizard just seems to hang - minutes go by and it may or may not ever ask for the next step and I end up assuming it has got a problem and quit.

On the pixhawk i can get through the left/right/front/back/top/bottom steps in under a minute…

also happens if you use the mandatory hw tab? ( i never used the wizard)

hmm - you might be onto something here - I wrongly assumed the calibration routine would be the same in the wizard as the mandatory hardware area - but it allowed me to complete calibration without any delays or issues, so thank you for the suggestion!

The only other thing I did differently was move the laptop a couple of meters away from the Navio2 in case the telemetry radios were too close together.

Now I need to work out why I have no satellites showing up!

being too close can be an issue, noticed from my x8r and my taranis, but only very very close;
are u using internal gps?

same here, when my taranis is too close to my drone I get a telemetry lost warning so i thought the same thing could be going on with the 3DR telemetry radios.

At the moment yes, the internal m8n with the antenna connected. I have a separate M8N I can try but haven’t tried yet - was assuming the internal one would get me going…?

how do you start arducopter? (sudo ArduCopter -A…)

I added the line: “sudo nohup ArduCopter-y6 -A udp: -C /dev/ttyAMA0 > /home/pi/startup_log &” to /etc/rc.local

what does flight data - status tab - gpsstatus and gpshdop and hdop say?

i just took the unit back outside and powered it up and the GPS has now sprung into life! I didn’t change a thing but it’s clearly now active: 11 sats, gpsstatus: 3 and HDOP 1.07 :slight_smile:

I had already changed the default settings as follows following some advice from another thread, is this correct?

GPS_GNSS_MODE 64 (default was 0)

apparently this this enables GPS, SBAS, GLONASS

GPS_SBAS_MODE 1 (default was 0)

GPS_TYPE 2 (default was 1)

By the way - I really appreciate your help with this, thank you!

if you wanna change default best would be:
GPS_GNSS_MODE 67 (or just 0)
GPS_TYPE 1 or 2 (doesn’t matter as far is know)
GPS_SBAS_MODE 1 (or 2 - both are ok)

Thanks - I tried GPS_GNSS_MODE 64 rather than GPS_GNSS_MODE 67 as I didn’t see the 67 option listed in mission planner and thought it might have been a typo… will give it a go.

give it a go and report back!.