Cannot activate the mobile data in Emlid Flow


I am setting up my new RS3 receiver and I cannot activate the mobile data. I tried to use different sim cards and different phones but still cannot activate the mobile data. I am not sure what to do. When I press the mobile data toggle, it remains gray. The APN settings are correct and the all sim cards that I tried are active. When I activate roaming, I can also turn on the mobile data but it quickly disconnects.

I have set up many Reach antennas before and never had this problem. Any solution to that? I have seen several discussions here in the forum but nothing specific that could help me solve this issue.

Hi @myka,

What SIM cards have you tried? Could you please share the Full System Report? Since it contains sensitive information, you can email it to us at


I tried two sim cards. The initial was data-only (4G) and other one, which is my own, is a regular sim cards for calls and internet. Sometimes I see the mobile data turns on but it quickly goes off.

I will send the full system report soon.