Cannort connect to IP

Hello,

just starting, stuck already. With both units in my Reach RTK Kit, I have the following:

I can connect to them when they are in hotspot mode, I can enter my wifi network details, and I can find the devices using Zenmap (on Windows 10 laptop) and Fing (on Android mobile).

Here is what Zenmap gives me on Windows:

Nmap scan report for new-host-2.local (192.168.2.139)
Host is up (0.094s latency).
All 100 scanned ports on new-host-2.local (192.168.2.139) are filtered
MAC Address: FC:DB:B3:8B:45:1D (Murata Manufacturing)

(for the other device, it’s 192.168.2.138 and new-host.local)

However, attempts to open http://192.168.2.139/ or http://new-host-2.local/ or http://reach.local/ in a web browser times out in all browsers, from both my laptop and my mobile.

The device address is solid green, as long as I put the antenna somewhere where it sees the sky.

What am I doing wrong?

I have seen advice about reflashing, but have not attempted this, partially because the on tutorial found suggested pushing a power button on the device which I cannot even seem to find…

I’m sorry, I can’t provide a Firmware version, not sure how I would obtain it.

Thank you very much for your help!

Tobi

If you type 192.168.2.139:5000
What do you get then?

Same timeout :frowning_face:

This site can’t be reached
192.168.2.139 took too long to respond.
Search Google for 192 168 139 5000
ERR_CONNECTION_TIMED_OUT

And you did try rebooting reach to boot up with autoconnect to assigned Wifi?

If unplugging and replugging USB power to reach counts as rebooting, then yes.

Sounds like flashing is the next step, Reach doesnt have a button, you just unplug/replug the usb.
https://docs.emlid.com/reach/common/reachview/firmware-reflashing/

BTW. When connecting to reach hotspot and sucessfully logged into Reachview, Reachview version is located at the top right corner

Hmm,
afraid that didn’t work either. Not sure if reflash was successful, I went through the steps as described on the website, including the workaround, but even though it completed without error messages, in the end the screen still showed “Firmware not detected”

This brings the reach back to hotspot mode, and I can open this website at 192.168.42.1:


I do not see a Reachview version here. Should I?

I enter the name and pwd for my wifi network and click to connect to it. It does show up in NMap:

Nmap scan report for new-host-2.local (192.168.2.139)

Host is up (0.29s latency).

All 100 scanned ports on new-host-2.local (192.168.2.139) are filtered

MAC Address: FC:DB:B3:8B:45:1D (Murata Manufacturing)

But connecting to http:/192.168.2.139/ or http://192.168.2.139:5000 or reach.local/ just times out in my browser.

What can I do to get my shiny toy to work?!?

Thanks for any & all tips,

Tobi

Slight update:
It now seems the blink pattern is:
white (with hints of red & blue on the edges) alternating with green, each lasting 2-3 seconds before switching to the other

In the velcome screen for reacview, add your wireless network credentials and let it connect to it. You might need to reboot the device.

in the end the screen still showed “Firmware not detected”

Dont mind this message,

Yes, I have added my wireless network details several times.
When connected to my wireless network, the reach shows up in the Zenmap scan, so presumably this means that on some level it is discoverable and hence connected to my wifi network?

Actually, just now when it was white/green blinking, it was indeed in hotspot mode, but now I reconnected it to my wireless and it’s blinking blue/green (alternating). And still times out :frowning:

According to
https://docs.emlid.com/reach/led-status/#time-sync
I now have

App running,
Wi-Fi client mode

which should be good news… but no luck connecting

Tried rechview app?
Googleplay https://play.google.com/store/apps/details?id=com.reachview
Or iOs
https://itunes.apple.com/us/app/reachview/id1295196887?mt=8

You should be good to go, something is not right indeed

Also, may i ask what your wifi password is and name of accesspoint?
If it has any rare letters or signe, it may cause reach to halt at handshake.
Please try a simple pass and AP name if els fails

Go things to work just this moment!!
Took device to work, used the work wifi, that seems to have made the difference. So I guess for now the message for anyone with a similar problem might be:
Try a different wifi network…
@TB_RTK, thank you so much for your help!

1 Like

Great news :+1: . You might wanna check my last tip above :wink:

@TB_RTK
Regarding your last tip above, strangely I would have thought that the work network is much less likely to succeed. It has a more complex SSID name and password, all sorts of firewall rules etc. Notably, in my work network, the Reach shows up with an IP address starting with “10.” whereas at home it starts with "192."
Btw, is there any way to force the Reach to get back to hotspot mode if I cannot connect to it through the wifi? I’d try to play with changing the wifi settings on my Reach to see if any combination works with my home wifi, but currently I need to flash the firmware to get it back to hotspot mode (as the Reach seems to think it’s working fine on my Wifi, even though it’s not visible for my browser or my Reach app on Android)?

You should not connect Reach to a network that hands out 192.168.2.xx addresses. Reach uses that subnet for ethernet-over-USB. If possible, change your WiFi/router settings to use a different subnet, like 192.168.3.xx. If you can’t do that, then you will need to change the hard-coded config file within Reach to make it use a different subnet for ethernet-over-USB.

What is happening is that Reach hears you making a request over WiFi and Reach replies back over USB. Since you are not connected to the USB, you don’t get the reply.

You should not connect Reach to a network that hands out 192.168.2.xx addresses. Reach uses that subnet for ethernet-over-USB. If possible, change your WiFi/router settings to use a different subnet, like 192.168.3.xx.

Oooh, now that would explain the situation! If this is the case then it might be beneficial for others to have this in the documentation.
I just googled this and found you had already helped someone else with a similar issue, in

Perhaps this should either be fixed or documented - how would I raise this issue?

Thanks a lot, I will see how I can now fix this (without upsetting the flatmates who share the wifi I’m on…)

Hi @tobi_kellner, we will add this to the docs, sorry about the confusion :slight_smile:

1 Like

@igor.vereninov, thank you!