Can not update to 2.23.9 (from 2.23.8)

I have tried multiple times to upgrade from 23.8 to 23.9. I have not tried the Flash utility but each time the update fails. I have a SIM card installed but I have disabled mobile data in the app in case there was an issue there. Any ideas on what the problem could be?

Left off, this is for the RS2

Is it hanging up and looks like it is not completing or is it giving you an actual error? I had a hanging situation on one of my RS2’s and the last update for my RS+ kit and rebooting revealed that the update had indeed completed. I would be leary of doing that though unless it is the same scenario for fear of bricking the unit and having to reflash.

Michael, it just fails but does not give any error message. I have rebooted the unit manually, and rebooted using the app multiple times. Same result each time.

I’ve been having this problem as well.
Tried different networks, (cellular & wifi) along with different access methods, disabling/re-enabling dev updates, and restarting every way I can think of.

I’m updating from 2.23.6 to 2.23.9

Everything is green until it hits “downloading update” when it immediately fails with
“Failed to perform update”

I could use the Flashing Utility but I will wait to see if it is a bug in the new update or if support has a suggestion to offer.

1 Like

@MDS where do you download the manual firmware flash versions from?
I tried modifying the tutorial link (2.22.7) to meet the latest 2.23.9, but that didn’t work.
Access to the root firmware directory is 403 blocked as well.
Thanks

Here you go. You can download the tool from this page. When you download the tool and run it, it will let you specify which firmware you are downloading. BUT now that I think about it, I have not used this tool for Beta, just latest released FW. Maybe someone else can shed light on using the Flash utility for beta versions.

I recently updated my Reach, M2 and M+ units with the Flash utility and it would not work on my Pix4D machine. I had to use and old laptop that I had and it worked perfectly fine. No idea why that was.

https://docs.emlid.com/reach/common/reachview/firmware-reflashing/

1 Like

This changes the nature of this thread, but I’m getting a libssl error when I try to run in Ubuntu 20.04

$ reach-firmware-flash-tool 
/opt/reach-firmware-flash-tool/Reach Firmware Flash Tool: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

I already have libssl.so.1.1 installed btw
Is libssl.1.0.0 an i386 architecture? This would explain it, if so. (I have AMD64 version of libssl.so.1.1)

That is similar to what I saw, but I never got the actual “X”, just the spinning loop. I probably just didn’t let it sit there long enough, but regardless the different outcome points to something else.

Found the download version @chascoadmin
files.emlid.com/images/reach-rs2-v2.23.9-dev.zip

1 Like

@geohawk are you going to just use the flash utility and update with the downloaded file?

@MDS - yes - flashing now…

update: flashed… rebooted (2x) and seems to be working fine with RV2 and RV3

2 Likes

When flashing to 23.9 you will get an error message that the FW is out of date. However, you can click on ignore and it will install without any problems. The out of date message may be what is causing it to fail when updating via the browser.

Successful install.

Where can we download dev firmmware for RS+?

Tried and found these:

http://files.emlid.com/images/reach-m2-v2.23.9-dev.zip
http://files.emlid.com/images/reach-plus-v2.23.9-dev.zip
http://files.emlid.com/images/reach-rs-v2.23.9-dev.zip

@geohawk where did you find the manual download file? I searched for it after getting the out of date error and could not find it. I used the file you posted and all was good.

@l3technologycambodia hopefully geohawk will post the link.

@MDS - I found the file using a logical naming scheme for programmers.

I also received that out of date error and ignored as well.

@l3technologycambodia - I’m not sure what the base naming scheme is for the RS+.
If you post that it should be “easy” to find.

I got the files from these links already. Thanks