Can a Septrentrio PolaRx5 be uses as a base station

I am wonder if it is even possible to use a non-EMLID receiver as a base station with the EMLID Caster service.

The server setup has a user name and password , however, the EMLID account I setup does not provide one.
Leaving it blank, I get a connection error.


Hi James,

Welcome to the forum! I see we’re already communicating via email. Let’s continue our conversation there to keep everything in one place.

In case anyone encounters this thread, we connected Septrentrio PolaRx5 to the Emlid Caster by changing the settings in the base from NTRIP v2 to NTRIP v1.


Hi, thanks, this (using NTRIP v1 to connect Septentrio Polarx5 as a base station) worked for me in the sense that the connection up, from Septentrio Polarx5 base station to Emlid Caster is now showing up (on my device) as functioning and delivering RTCMv3 data. In the base station configuration, though, there are a LOT of message format options. Is there a list of those that the Emlid Caster service really wants or needs, and/or a list of those that the Emlid Reach 2 that I want to use as a rover specifically will want or need? (I haven’t yet been able to obtain a fix yet). I can’t possibly have to select them all, or be certain that the defaults from Polarx5 are the good ones. PS Onocoy, which I am also trying, is very specific about which message types to pass. PPS I have now simply passed the same messages to Emlid caster as I do to Onocoy. PPPS reveals that my station, MP16777 is showing up with STR;MP16777;none;RTCM3.0;none;none;none;none;none;none;none;none;none;none;none;B;N;none;none which suggests it is not receiving anything after all?

Sounds like it is expecting rtcm3.0, it should be expecting RTCM3.2, I would expect?

1 Like

Dear wizprod, thanks for the suggestion, indeed it’s showing on as RTCM3.0, like all the other mountpoints that say none (do none of those work, either?) while the RTCM3.1., RTCM3.2 and RTCM3.3 are showing up with meaningful numbered messages.

I suppose now I have a Septentrio question and that is, how can I make my PolarX5-3015983 send out RTCMv3.1 or above?

That is not something I appear to be able to do even in the Corrections -> Corrections Output -> Advanced Settings.

So maybe this is where this thread will end? Unless there’s a patch or a firmware upgrade, I would need to check in with Septentrio.


Emlid Caster doesn’t need anything, just the ability to pass corrections via NTRIP; it all depends on which corrections can be accepted by the receiver. Reach devices support the correction input in the RTCM3 format. I’d also double-check with the Septentrio what type of corrections it can output.

From the mount point, it looks like no corrections are being passed, and the issue is from the base side.

You can also double-check the connection to the internet.

Thank you, that is interesting and clarifying (“Emlid doesn’t require anything specifically, just retransmits”, that does make sense now). But on the other hand, my Septentrio PolaRx5 IS alive and well on the internet, and I am sending NTRIP connections successfully to onocoy (and managed to successful using my Emlid Reach RS2 to receive them from After that I made the same setup to Emlid, and both paths out are blinking happily and showing other evidence of contentment. On the port they show up as STR;USANEWPRI1;0008;RTCM 3;1005,1077(1),1087(1),1097(1),1117(1),1127(1);3;GPS+GLO+GAL+BDS;onocoy;USA;40.35;-74.65;0;0;;;B;Y;0; but on the they stubbornly remain STR;MP16777;none;RTCM 3.0;none;none;none;none;none;none;none;none;none;none;none;B;N;none;none. So I am not sure as to what’s going on there now.


Can you share your settings (screenshots will be perfect) for both Septentrio PolaRx5 and RS2? I’ll look into it.

1 Like

Thank you very much! I posted what Septentrio shows me, and what your caster network shows me. And how Onocoy deals with it well. Below is what the RS2 shows me.


Thank you for the photos.

  • On the RS2, do you choose the mount point from the list or manually type it in? You need to chose it directly from the list. Do you see it on the list?
  • Do you test outside? Please check if you can connect outside.
  • Do you see that the rover is online in Emlid Caster?

Hi Olesia, Short answer, it now works, thank you so much! The mount point came up, we were outside, but I had confused the base with the rover. Conclusion: we are able to serve connections from Sepetentrio to Emlid and back down to rover, and all is well. Also been trying RS2+ and that’s been working smoothly as well.



Thank you for updating me! I’m glad to hear it worked out.