Calibration light on NAVIO2 board not working when using Precompiled NAVIO2 Builds from Ardupilot firmware

Hi guys,

I was trying to get a reverse tri copter VTOL plane (as in this link https://discuss.ardupilot.org/t/reverse-tricopter-vtol-plane/39829/71) working using the NAVIO2.

As the code to support this motor mixing is not in v 4.0.0-stable I tried to get the precompiled 4.1.0-dev from here https://firmware.ardupilot.org/Plane/latest/navio2/.

Before starting this exercise I have updated the Raspian image to the latest Buster image provided by Emlid.

Then following the instructions given here -> Navio2 Arducopter upgrade, I updated the binary.

Then running sudo emlidtool ardupilot, I can see that the Arduplane program starts up as per Emlidtool (see screenshot) - however note that the version is displayed as 4.0 instead of 4.1

During this process of start up I was expecting to see the calibration light switch between red and blue (which works when I use the build supplied by Emlid as part of the Raspian image) but this did not happen. Also once the startup is complete the green light flicks on and off. This also is not happening with the pre-built binary.

But upon connecting to Mission Planner I can see that the version has been updated to 4.1.0 Dev.

I also tried to go back to the prebuild binary 4.0.0 - stable and tried to run that. Now this is the same version shipped with Emlid’s Raspian OS. However this also did not turn the light on during calibration and startup.

Is there something I am missing?

Any help would be appreciated.

Hello,

There is a bug somewhere with the Led sequence. We have the same problem with arducopter. Led blink green at early boot then stay Off.

Emlidtool reference is the 4.0 folder… With my “upgrade” tutorial, I only swap the arduxx file without other modification.

Thanks heaps @mlebret. I thought that that might be the case but good to get it confirmed.

The only thing I couldn’t get my head around is the arduplane version 4.0.0 shipped with the emlid raspian (buster) didn’t seem to have this bug but the version 4.0.0 arduplane binary downloaded from the ardupilot firmwares page has this bug. Is this something Emlid are fixing in the arduplane version shipped with the latest Emlid raspian (buster)?

Waiting eagerly for ardupilot 4.1dev to become part of the stable branch. :slight_smile:

Thanks again for the awesome tutorial @mlebret!
JD

Hi @JDAS,

Just wanted to add there was indeed a bug with the LEDs that we fixed in the new image :slight_smile:

Hello,

I have a Navio2 with latest image and Arducoper 4.0 on a Pi4. Led bug is still present. Led flash Green at boot then remain Off.

Hi @polina.buriak - thanks for the update. Do you have a release schedule planned for 2020?
@mlebret - interesting that you are seeing this issue. I saw that if I use the (latest) build provided by Emlid on my Pi 3B+ for Plane 4.0.0, then I don’t seem to have the LED issue. Wondering if this issue is specific to Copter only.

I did a check with a fresh image.

Arducopter 3.6.11 (provided on the Emlid image): Led flashing is OK
Arducopter 4.0 (from firmware.ardupilot.org): Led is off after Green at boot time.

Hey there,

There is a bug in ArduPilot’s source code that we’ve fixed in our latest image. However, if you build from ArduPilot, this bug will be present.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.