Burning navio 2 image to raspberry pi 3 - USB partition issues


I downloaded the image and copied into my 32gb sdcard using dd as per the instructions in https://docs.emlid.com/navio2/Navio-APM/configuring-raspberry-pi/

I am not able to use the full 32gb of the ssd. Also, I am not able to extend the Linux partition which the image has. I need to extend the “/” (root) partition so that i am able to install the software I need. I tried using fdisk, parted and gparted several times, but, it does not work.

have anyone extended the default partition created by the navio image?

Why are you extending the partition to the USB?

If you just want to extend the partition on the sd card raspberrypi has several instructions for how to do that.

i meant ssd card. it has 32gb. so, when I install the navio2 image into the 32g sd card. All I have is less space to install other things like ardupilot, node.js and modules. it is out of space. so, I need to utilize my full 32g space. so, I created a new partition and formatted it to fat32 and mounted it. but, the ‘/’ parition is out of disk space.

well, now, I have reformatted my sd card. installed raspbian os and installed node.js
 but, obviouslly, apt-get install apm-navio2 does not work since it cannot find it. (and yes, I I did follow the instructions from the raspberry website)

Your making life harder on yourself :slight_smile:

I have either a 32 or 64gb on mine when I was installing ROS which is like 7gb of compiled tools.

IIRC you run this over SSH, enter in your config, reboot and it resizes it and in a few minutes done.


Thanks. that worked. I just tried it on my another 8GB SD card.