Bluetooth in emlid reach position output

Hello , I have an issue in position output using bluetooth in my emlid reach device. I paired a device and it was working well till a specific update (I don’t remember exactly its version) . Since this update I have to open ReachView app through the ip and restart bluetooth every time I restart my device to make it work well.
I received 2 or more updates after that and they didn’t solve this issue.
Any help?

What device are you trying to pair?

A laptop with Ubuntu 16.04 OS.

What Emlid firmware are you on currently?

I’ll check which version exactly and return back.
But I’m sure it’s the latest available stable version . I checked for updates 2 day ago and it said I’m up-to-date.

1 Like

My current version is v2.16.2

What software do you use to recieve Position output data?
Can you try another PC or mobile phone to make test?

1 Like

Hi @ma7moudk,

May I ask you to try our latest v2.17.4 dev update? It resolves some issues with BT transmission.

Please follow this guide to update Reach to this firmware. Note, that you need to enable dev updates on your device.

Keep us posted.

1 Like

I’m using python bluetooth library using the attached code: . (902 Bytes)

I used another PC and there is the same issue . I’ll try phone tomorrow.
I can receive bluetooth well as soon as I restart bluetooth from reachrover app.
My problem is why I need to restart every time I power on the device.
Thank you

Thank you . But my device is Reach .
And according to this comment (ReachView v2.17.4 dev release) Reach hasn’t received this update (v2.17.4) yet .I’ll have to wait till this update is available.

I tried receiving bluetooth data using a mobile phone and the same issue happen.
The emlid device doesn’t even pair to my mobile phone successfully until I manually restart bluetooth using ReachView app.

Hi @ma7moudk,

Sorry, I missed the fact that you use Reach device. Reach and Reach RS devices don’t have such issues with BT connection.

Do I understand right that the BT connection works flawlessly, but you need to re-enable BT in ReachView every time after you power the unit? Could you please post the screenshot of the ReachView BT tab before you restart BT?

Yes exactly.
Here are the steps I do:
a- Power on reach device
b- Try to connect to the device using bluetooth library in python . I receive error “Host is down”
c- Open reachview app . As you see in the 1st screenshot ,My laptop (Hema-omen) is in the paired device but the sign of pairing doesn’t appear.

d- I restart bluetooth and retry the same code , it works perfectly and the sign of pairing appears beside my laptop name as in the second screenshot.

e- After that I can connect and disconnect smoothly , there arn’t any problems. The problem appears only if I restarted the device.

Note: I usually pair with only one device . There are other paired devices in the screenshots because I tried another laptop and mobile to check if the issue in my laptop but the same thing happened.

Unfortunately, I could not reproduce the issue with Ubuntu 16.04.
Every time I boot the device, Reach connects to PC via BT.
As for the code side, I’m afraid, I can’t help you with it.

1 Like

Thank you .
But I’m not sure that this issue is related to Ubuntu or my code because I tried it with a bluetooth android app in a mobile phone and the same issue happened . It doesn’t connect to the mobile and send data until I restart bluetooth.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.