BL Heli ESC's

Hey there,
has anyone used BL Heli escs on the Navio 2 Board?
I have read, that the don’t work on the Pixhawk, so I am curious to know about the Navio.

I fly my quadcopter with a Qbrain 25A 4in1 ESC flahed with BLheli and a Pixhawk. It flew before with a Navio+. Why should BLheli not work with Pixhawk/Navio? APM has no Oneshot support yet, but BLheli works with a normal PWM signal too.

Yep I can Confirm that they work. Ardupilot copter has a parameter MOT_PWM_TYPE default is 0. Mode 1 and 2 are for oneshot. I think had this running before I re-flashed my pi, which reminds me I’ll have to set it again.

“To enable oneshot set MOT_PWM_TYPE to 1 or 2. It defaults to zero which gives the old behaviour.
With MOT_PWM_TYPE=1 the PWM pulses are synchronised with the main loop. This reduces latency and should give a bit more phase margin.
With MOT_PWM_TYPE=2 the PWM outputs are also divided by 8, giving a range of PWM values of 125usec to 250usec. This is commonly called “OneShot125”. That reduces latency even further. Your ESC must have specific support for this output mode, and you will need to recalibrate your ESCs.”

I didn’t recalibrate my esc’s and instead applied min values via the blheli firmware using an arduino which I highly recommend in order to know whats going on with those esc’s. I’m not sure the logic in that but it works and has stopped the startup issues I had with the motors.

I’d be interested in the Damped light feature, it seems to be working fine on my rig (f450) but I’ve heard it’s unnecessary for larger than micro rigs as it’s aimed to cease the motors quickly to speed descents which smaller copters don’t have the weight to do naturally. Good video showing damped light effects here

Ok stange.
I’ve looked into my current setup and I had oneshot turned off (MOT_PWM_TYPE=0) in mission planner. And all is fine. I enable oneshot (MOT_PWM_TYPE=1). And all is fine (testing indoors can’t review performance). Setting to oneshot 125 (mode=2) however does not work.

So it seems that my esc’s don’t support oneshot125 which I think I knew already but can’t remember why exactly.
But when I check out the esc in blheli suite I’m surprised that enable PWM input is switched to off. Which in theory means that if ardupilot/mission planner is set to output PWM (oneshot off. MOT_PWM_TYPE=0) the motors should not be running as the esc’s are programmed not to accept PWM in case low loop rates confuse the esc’s into thinking that the oneshot signal is in fact PWM.

So either ardupilot is lying when it says it’s using oneshot or the esc’s are in fact accepting PWM input when set not to.

Okay, I think my original question was wrong :smiley:
It seems like only Emax BlHeli ESC’s have gotten Problems with the Pixhawk.
Sorry for confusing this…