Beta v2 image with ROS support for Navio boards

I have tried ROS version on Navio+. The installation is straight forward from new image in scratch. I could not upgrade ArduCopter from previous image. No change of large compass offset on compass calibration.
Anyway, I appreciate effort on ROS by Emlid team.
Do you have any plan to implement MAVROS offboard control or something?

is it possible that compass #2 has about 45degrees (anticlockwise) mismatch to real orientation and compass #1 about 90degrees (anticlockwise) mismatch to real orientation in the latest beta image (20161201)?

i am using (AHRS 180yaw orientation) and also PLUS frame configuration;

i’ve been playing around multiple times now but the only thing i am really sure about is that compass #1 and #2 (or #0 #1) differ about 45degrees in my setup;
(and point into wrong directions as stated above)

AHRS is set to yaw180 and mechanically mounted as PLUS
my external compass (hmc5983 -YAW90 - mechanically mounted as PLUS) is pointing to the right according to Navio’s front (but left according to frame orientation) and pointing to the correct orientation;

Compass calibration Onboard always stops at 30%-60% (either only external or all compass activated) and live calibration does work and gives offsets which make sense - but Mission planner still reports compass not calibrated after reboot…

i used the 20160718 image - could calibrate accs and onboard compass calibr, external compass does not point in every direction correctly…but internal compass works for now;
i have a second sdcard with updated beta image and will test again tomorrow to be sure what’s really related to the beta image…

Could you please elaborate on this one?

The new beta is incompatible with old stable release. That’s why unfortunately you’ll need to tune your drone once again. The differences between releases are too vast to make a seamless upgrade.

MAVROS is preinstalled. So, I expect beta docs to be disclosed later this week or even today. They might clear up the confusion a bit.

Have you tried upgrading MP? This might be a GCS-side problem.

Don’t think so. The orientation of AK8963 hasn’t changed between releases and LSM’s has been fixed in the beta allowing to use Live Calibration in Mission Planner (even though, it’s slower and not as reliable as Onboard calibration). Both changes couldn’t mess up with the orientation. May I suggest to sudo rm /var/APM/ArduCopter.stg and calibrate from scratch?

@george.staroselskiy, thank you for the comment.
Exactly what you mentioned. I did all over again, not so hard:-)
I am looking into document for PX4 for my reference.
Appreciate it, if you prepare documents for emlid.

Guys,

We’d like to share documentation for this beta release. As it’s not documentation for stable distribution yet, we won’t update docs.emlid.com right away.

Check out this branch which has all the needed instructions how to use the new beta.

They contain comprehensive entries on ROS which will help get you started!

2 Likes

I downloaded the beta release image and tried the tutorial in the branch. I was able to run roscore using the tmux interface as instructed. I then did the rosrun command. In another tmux window I can run rostopic list and I get a series of mavros topics. Now I have trouble - if I try the rostopic echo /mavros/imu/data command as shown in the tutorial I get nothing. Crtl-C to break an get a prompt again. Then I tried rostopic echo /mavros/state and I get an output but it does not update as it should.

Anyone else tried this image and the ROS tutorial ?

@vinorobo

Have you connected with a GCS to ArduPilot?

Yes. It is connected via telemetry on UART. MP is working fine.I just cannot get the rostopic to echo anything useful. ROS must be running because I do get rostopic list

@george.staroselskiy Thanks to you and your team for all the hard work! :slight_smile:
Does this release also include wifibroadcast?

1 Like

Thank you for your warm words!

This beta does not but we’ll try to stick it into the next one.

Did you try waiting a bit? Or it just hangs and outputs nothing? I noticed it’d taken some time to pick up topics from ROS (might even take a minute or more).

I will try again but if echo takes that long how can it be useful. Do you have any examples of ROS nodes running on the navio2 ?

Thanks! May I mention that you guys should check out this thread while implementing, I’m sure you guys know about it but doesn’t hurt to make sure.

It seems they have included several patches for mavlink, joystick, and I believe they were working on patches to allow you to change the power output and bitrate of the wireless card.

Thanks!

Has anyone got the mavros topics to work ? Any simple ROS node to test ? Is is possible to send the mavros topis via ROSserial to host computer running ROS ? Excited about getting the ROS topics in navio2 beta but so far no success in getting anything useful.

@vinorobo
You can try the following command before launch rostopic:
rosservice call /mavros/set_stream_rate 0 10 1
It sends stream rate request to FCU.

No. Did not help. Exactly as before. I verify that ardupilot is running. GCS is getting data. roscore running. rosrn command in another terminal running - got [INFO] lines all seem to be good. Can get rostopic list in another tmux window but then rostopic echo just hangs until crtl-C

I do not think the ros node works correctly. As a workaround I am going to mavlink the ethernet port to a companion computer and run mavros there. Then do all the ROS work in the companion and send commands back over mavlink to the navio2. Should work ?

This topic seems to have died. No responses. What gives - does the ROS node in navio2 betav2 work ? Anybody ?