Battery monitor pin

Hi i have a problem with the navio+ battery monitor. Via ssh and the python example i get the following readings:
A0: 1.1405V A1: -0.0232V A2: 0.5747V A3: 0.5750V
Although through missionplanner i get no readings at all, 0V and 0amp. I’ve tried to switch to all different currunent and volt pins (A0-A13).
Picture of setup:

To get your battery status try to enable monitoring of the battery’s voltage and current and set the right pin. For Navio+ it should be 2. Just look at my screenshot

How do i enable it? Where is that option?

Some debugging info:
All of these outputs give 0 volts in mission planner, although i get -39.9 amps with some options.

i’ve also tried switching out the df-13 cables and measuring the pins directly on the board gives the same results as the example.

Thank you for screenshots.
Although you have the right parameters for the second battery (BATT2_VOLT_PIN and BATT2_CURR_PIN) you have to set appropriate parameters for BATT_VOLT_PIN and BATT_CURR_PIN. So it should be 2 and 3 rather than 100 and 101.

As stated in my original post,i’ve already tried voltage and current pins (0-13).
I tried it again but got the same results:

This topic was automatically closed after 100 days. New replies are no longer allowed.