Battery drain when Reach RS is turned off

I’m having problems with battery on (Rover) Reach RS. It was 30 days turned off and when I tried to turn it on i had no success. I plugged a powerbank on usb and everything worked well…
I bought another batteries and install it on Reach… Powered it up to 100% and made some tests with ntrip and RTK and everything works…
I made a test yesterday before turning off my Reach RS with 84% of battery and 36 hours late I started it to check the battery and it was on 80%.
I’ll let it turned off more 2 days and check again.
Someone had problems like this???
Battery draining when reach is turned off?

Hi Caca,

In such cases, we strongly recommend first contacting our support at support@emlid.com or here on the community forum. Then we’d be able to help you determine the issue.

Unfortunately, now that you’ve replaced the battery, it’s rather difficult to understand what the initial issue was. Please note that we don’t recommend disassembling our units and changing the hardware components.

1 Like

Thanks for the advice Polina… We tried to fix changing the batteries with exactly the same model and the item isn’t on warranty.
I left 3 days turned off and the battery keeps draining…

Hi Caca,

I’m afraid we can’t be of much help here. After the exchange of the hardware components, there is not much we can do to determine the initial issue.