Base RS+ unit not booting

My base unit seems to just flash orange/green (no blue) and wifi never seems to come online.

Has anyone seen this before? Relatively new unit…less than 1yr old

edit & solution: The downloadable flash tool couldn’t make any headway (would detect the device and download firmware but would fail when trying to upload) but at some point while starting and restarting the unit I had it plugged into power (not USB on the computer) and it seemed like it started a regular boot cycle and conneced to my wifi. Battery was still somewhere between 30-50% according to the little icon in the app once the green light went solid and I was able to dialup the webUI. Attempting the update via the webUI stalled with all the “test” stages with spinning and non completing. On a whim I thought I’d try from my phone and Reachview3 was able to download the update and get it uploaded successfully.

Honestly…I’m not at all sure if anything I did made any difference but I’ve now got both the rover and base updated to 26.4

If you know what occured here, feel free to reply to help others.

Hi Kristofor,

This is an unexpected behavior from the Reach RS+ unit. It seems like there could be some glitch at the start-up. To get a better grip on what happened, we’d be interested in checking the Full System Report from the unit.

The info will help us to check if your unit is working correctly now and search for the reason for the previous behavior. As the report contains sensitive information about your unit and its networks, it’s better no to post it in public.

So please share the report via PM or with me so that we can take a look. You can find out the process of downloading it in our guide.


Thanks for the reply!

Since the firmware update to 26.4 (pardon if I got that number wrong…the latest one recommended in the web gui) they seemed to be booting properly (lights did their cycle thing…pwr and net go solid & green blinks once per second) but I’m unable to connect to them via reachview3 even though I do see the SSID being broadcast once it’s in ap mode. I’ll fire it up in the office where I know they were both was linking to the office wifi.

Thanks for the guide…I’ll follow it shortly.

Ok, so after the firmware update (one via the webgui on a pc while connected to my office wifi, the other via the reachview3 app while also on the office wifi. The updates seemed to work and they rebooted and were accessible from the webgui on a pc (I didn’t try the reachview3 app…just forgott)

Once back in the field set up both base and rover, was able to connect to their wifi AP as expected but the devices weren’t detectible in reachview 3 but I didn’t have time to debug. I do believe I had a solid net light on the base but it was very bright out so I may have just been able to see the blinking. I packed up and brought both units back to the office.

Now in the office, both devices are in the window with a solid pwr, slowly blinking net led (probably once per second) and a stat light blinking twice as fast as net.

I did some port scans of the two devices and I’m seeing ports 22 and 2000 are open, nothing web. Is there anything I can do via ssh to dump the config or reset them or download the full system report as I’m currently unable to access either device via web or reachview in either ap mode or wifi hotspot mode

quick update. I found another thread with ssh credentials so I have a bit more info to post about services and ports:

$ netstat -lntu
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0* LISTEN
netstat: /proc/net/tcp6: No such file or directory
udp 0 0*
udp 0 0*
udp 0 0*
udp 0 0*
udp 0 0*
netstat: /proc/net/udp6: No such file or directory

Hi Kristofor,

Thanks for the detailed description!

Please reflash your device according to our guide. It should resolve the time mark issue you’ve experienced.

Would it be possible to remember what version you’ve updated from? This info will help us to understand what triggered the initial issue.

I want to say I remember a 24.3 or something like that but don’t recall.

I tried he flash tool. In the last stage where it flashes he device (after device initialization and unpacking) I see the device mount as a drive in windows 10 then the flash fails with a timeout error. Is that normal? Most flashing processes I’ve done in the past does all the flashing steps while the device is (40.3 KB)

So I tried again with a friend’s help and we found the flash tool was failing on a certain usb port but did work on a different usb port on the back side of the pc. Both were usb 3 to my knowledge but I though I’d feed that back to you in case it helps.
TLDR: in the flash stage it would mount as a drive and timeout on one usb port. As soon as we plugged it on another port it seemed to work as expected.

I’ll be testing both devices and will report back later today.


Hi Kristofor,

Do I get it correctly that you managed to reflash your units?

Just wanted to post a quick update from Kristofor that after the reflashing the units are up and running :slight_smile:

I’d also point out that the reflashing issue looks related to the specific USB port. The solution to this is to either check different USB ports or use the powered USB hubs.

You can always reach out to here or via in case you have any questions regarding any step of working with our devices.