Base - Rover settings over TCP (wifi)

I have used my Reach modules (orig.) in single mode but never in RTK mode and thought I would experiment. I have them both connected to my home wifi and can access both of them on my laptop.
However, no matter which settings I change, I never see any indication that they are communicating with each other. Unless I missed it, Emlid documentation does not really spell out which exact settings on each unit that will result in a Base -> Rover configuration.

One thing I noticed is that in any of the client/server fields, the location was pre-filled with “localhost” and I can not edit that field. Since the 2 units are on different IPs, on the same network, I thought I should be able to specify the IP of the Base unit as the source of corrections in the Rover unit, but that field cannot be changed.

Anyway, Can someone please share the minimum settings for each unit, on each tab, that will (should) result in the connection?

Thanks!

Hi @dpitman,

Your settings should look like these:

Base mode:

  • Role: Server;
  • Address: localhost;
  • Port: 9000.

Rover correction input:

  • Role: client;
  • Address: Base IP address;
  • Port: 9000.

You need to get at least Single status on Base unit to get corrections.

Thanks Tatiana,

I had mistakenly thought that i couldn’t type in the Base’s IP in the corrections tab on the Rover. It is grayed out in the Base Mode tab of the Base but indeed editable in the Correction tab on the Rover.

1 Like

You may have already seen this, but here’s the default base and Rover configuration. This one uses LoRa to send the corrections, but the rest of the settings are the same. Once you’ve got everything connected you can verify that you are getting corrections from the status graph on the rover.

Reach RS Base and Rover Setup

Much more info than the Quick Start for the modules. Thanks!

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.