Emlid

Community Forum

Base Corrections not coming through (via 3DR link)


(George) #22

These photos show what you are describing but I am not sure if it matters (I could be wrong, never tried it). If you want to connect a PC to REACH’s USB port, you would just use a USB cable and if you want to connect the 3DR to the REACH’s USB port, you would use the OTG cable (and the power gets fed to the REACH’s UART port). On the other hand, if you want to connect a PC to REACH’s UART port, you would need a UART-to-USB converter and if you want to connect the 3DR to REACH’s UART port, you would just connect it (and the power gets fed to REACH’s USB port). Note: a PC could also provide the electric power via its USB port…



(Shaun Bell) #25

I seem to be having the same issue. Both radios are UART. I thought maybe I needed to turn off input corrections on the base and disable the rover from sending corrections. Didn’t help. Still no grey bars. Works great in WIFI mode. Radio’s are set to the same net ID and are solid green with flashing red. So connected and sending/receiving data.


(Egor Fedorov) #26

Make sure the radios and Reaches are all configured to use the same baud rate. It just might be the problem.


(Shaun Bell) #27

Everything is 56,000. So weird. Go back to tcp and everything works. The cable is swapped for TxRx, so that shouldn’t be a problem. Any other ideas?


(Shaun Bell) #28

Checked both radios. Both connect to each other, one as the ground station and another hooked up to a pixhawk. Both also connect to all my UAV’s. LED’s on the radios are solid green with red flashing, so data’s being sent. Still no happy grey bars.


(Shaun Bell) #29

Here’s the settings of the Base and Rover. Note I turned off input corrections on the base and base settings on the Rover. Didn’t help though.


(Egor Fedorov) #30

Shaun,

Can you please confirm the radios are working by themselves? Connect them to a PC and use a terminal emulator(e.g. Realtem) to work through the COM ports.


(Shaun Bell) #31

I actually hooked one up to the laptop and used it with Mission Planner as a GCS and the other to a Pixhawk and they communicate. Swapped and tested again with the same results. So both are working on the same ID.


(Egor Fedorov) #32

Great. What baud rate did you use with your PC? Also, what messages do you have turned on on the base? Does it have satellites visible?


#35

It’s been a while since the last posting in this thread but I just wanted to share my experience.
Tried to get RTCM3 data from Base (Reach) to Rover (Reach) via 433 MHz SiK-Radios (3DR type).
Read some threads here in the forum and tried altering settings … nothing helped.

I got it working, but needed a Laptop running RTK-Lib (strsvr.exe).
The way I got it running was to set it up like:

  • Base Reach with its Hotspot running (or connected to a Wifi on site)
  • Rover Reach with 3DR-Radio connected to DF13 on Reach (next to USB)
  • Laptop with RTK-Lib (strsvr.exe) connected to the same Wifi as the Base Reach.
    There is also a 3DR-Radio plugged into the Laptop.
    (mine is connected via an FTDI-adapter since my 3DR-Radio doesnt have a USB-port)

Data Flow

  • Reach as Base > sending (Base Mode) RTCM3 via “TCP/Server”
  • The Laptop has strsvr.exe running and as Input it uses the RTCM3-Stream via “TCP Client” > as Output “Serial” with the COM-port where the 3DR-Radio is connected to
  • Reach as Rover > receiving “Corrections Input” as RTCM3 via 3DR-Radio as Serial set to UART

(Angel Espinal) #36

I have tried RTKLIB in a different way, but in theory the same principle, and did not work, i will try this setup and see what happens.

Thanks.


(Facundo Pessacg) #37

Is there any update on this topic? I’m having the same problem and I cann’t find a solution.


(Tatiana Andreeva) #39

Hi @facu.pessacg,

May I ask you to create a separate topic with the detailed description of your issue?
Thanks!