Emlid

Community Forum

Bad GPS Signal Health - No PI Camera


(RK425) #1

Hi I have a UGV running a standard Navio2, It ran brilliantly for a few weeks, and suddenly I am getting bad GPS signal health. It seems strange to me as I still have 20 satellites and a HDOP of 0.6, and the GPS status through Mission planner comes back as 4?

There is no raspberry pi camera as that is the usual suspect. I am running wifi as the communications and there is a separation of over a meter between GPS antenna and the 2.4Ghz antenna. I have a 433Mhz RC unit, but when its turned off I still get the bad GPS signal health.
I thought it might have been the Pi’s Wifi, so U switched to an external Wifi unit and turned off the pi’s wifi and Bluetooth.

I have tried to find out what the actual GPS signal health means, it cant be HDOP or fix related as I have a great HDOP and a very stable 3d position fix?
What does the actual GPS Signal health mean??? If I knew that maybe I could chase down the problem as it doesn’t appear to be interference related.


(Tatiana Andreeva) #3

Hi @ralphkoch,

As far as I know, you get this message if the GPS unit outputs the coordinates to autopilot rarer than 5 times per second.

Do you use Navio2 built-in GPS module? Is there anything you changed in MP parameters that could affect the GPS update rate?

Could you post here hardware setup photos as well?


(RK425) #4

Thanks for the reply,
As far as I know I haven’t changed anything, it should all still be default with regards to the GPS. Do you by any chance know the parameter or parameters which govern the update rate for the GPS?

I will post some Pics tomorrow, its a fairly big tracked robot, and is out in the workshop (dark and cold now) and if I am honest the last two days of trying to find interference issues makes the internal wiring look like a cyclone hit it and to save embarrassments I will clean it up before the photo :slight_smile: Again thanks for the speedy response.


(Tatiana Andreeva) #5

@ralphkoch,

If you haven’t change anything, it might be an issue with the hardware setup. Please post here hardware photos once you’ll be able to.