Bad Baro Health

It is necessary to provide following information to get help:

  1. Image and ArduPilot version.
  2. Detailed problem description. How does observed behavior differ from the expected one?
  3. Your step by step actions.
  4. Picture of the setup and connection scheme.
  5. If using any additional hardware please provide exact make and model.

u-blox 0 HW: 00080000 SW: EXT CORE 3.01 (107900)
Frame: QUAD
APM:Copter V3.4.6 (e707341b)

I am trying to connect PX4FLOW to Navio 2 and let it fly.
However, if PX4FLOW is set to Enable, the barometer gets abnormal.
And the propeller stops.
Can I use PX4FLOW in Navio 2?

http://ardupilot.org/copter/docs/common-px4flow-overview.html
I worked in the procedure described here.

pi@navio:~ $ i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – -- – -- – -- – -- – -- – -- –
10: – -- – -- – -- – -- – -- – -- – -- – --
20: – -- – -- – -- – -- – -- – -- – -- – --
30: – -- – -- – -- – -- – -- – -- – -- – --
40: – -- 42 – -- – -- – -- – -- – -- – -- –
50: – -- – -- – -- – -- – -- – -- – -- – --
60: – -- – -- – -- – -- – -- – -- – -- – --
70: – -- – -- – -- – 77

Can you try lowering the i2c_baudrate in /boot/config.txt to 400000? This should help

Thank you for your reply.

[Before]
pi@navio:/boot $ cat config.txt
[all]
dtoverlay=pi3-disable-bt
dtoverlay=navio-rgb

dtparam=spi=on
dtoverlay=spi0-4cs
dtoverlay=spi1-1cs,cs0_pin=16,cs0_spidev=disabled
dtoverlay=rcio
dtoverlay=navio-rgb

dtparam=i2c1=on
dtparam=i2c1_baudrate=1000000

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

#dtparam=audio=on

start_x=1
gpu_mem=128

[After]
pi@navio:/boot $ cat config.txt
[all]
dtoverlay=pi3-disable-bt
dtoverlay=navio-rgb

dtparam=spi=on
dtoverlay=spi0-4cs
dtoverlay=spi1-1cs,cs0_pin=16,cs0_spidev=disabled
dtoverlay=rcio
dtoverlay=navio-rgb

dtparam=i2c1=on
dtparam=i2c1_baudrate=400000

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

#dtparam=audio=on

start_x=1
gpu_mem=128

Is this OK?

This should then become dtparam=i2c1_baudrate=400000.

This topic was automatically closed after 100 days. New replies are no longer allowed.