Bad altitude on mission planner

I have an issue with navio2 + raspberry pi 2B.I have installed the latest image 20160408 and apm 3.4 (unstable).
Alt info (gps alt and REL alt)in mission planner and APM planner 2 appears always as 0,00.The quad cant fly alt hold and any other modes that requires altitude.
The altitude value sometimes seems to increase or decrease a little over time (0.02) but not as it should be.Im used to apm 2.6 board and when everything goes well alt readings are constantly going up and down,not much but something ,this alt in navio is completely static and it began to occur after updating apm and img for raspberry to latest.
Also the quad flies very smooth on stabilized but as soon as i put it into alt hold,it doesn’t hold anything.
I don’t know what could be causing this,bad Baro?.i have run the C++ example and it seem to be ok.
im new to linux and my english leaves much to be desired so be comprehensive.

This is the quad

The alt issue on mission planner

Baro C++ example (apm is not running same time)

i had also some gps problems to get a fix in previous apm version but thats another topic.
Thank you.

Hi Axel,

Could it be the case that the foam that you used to cover the baro is air tight? Can you try removing it and testing with real time baro alt graphs in mission planner?

Hello and thank you for replying.

I am using the same foam as the apm boards,i can breath trough it.Same problem with or without foam.
if i run other sd on raspberry ,this one with same kernel but previous apm version the altitude seems to start working but then the gps don’t catch any satellites and also alt hold don’t work properly.

Yesterday i leave the raspberry + navio2 latest apm and kernel(not upgraded) versions and after 15 mins connected ,altitude suddenly started to work.Today i leave the flight controller connected for 1 hour but still nothing.
Should i upgrade the kernel,which command to use?altitude graphs which ones?I think that is what you are asking for.

I only have made one flight after installing newer kernel and apm versions.This flight was good,alt hold,loiter,satabilized,RTL and land worked perfect but after powering down the flight controller alt issues start happening.So maybe dust into the baro? i have ordered 1 new baro so if cant solve that by software i can replace the sensor.I hope not.
I also tried another brand new raspberry pi 2B that i had laying around but same problem so i think raspberry isn’t the problem.


Hi Axel,

Could you please upload the logs from the flight when you had the issue?

Sorry for the delay.i was very busy this week.
i put here two logs,one is for the good flight and the other is one bad, i hope you can reach a conclusion.

good.tlog.nav (1.4 MB)

badalt.tlog.nav (1.3 MB)

i didnt touch anything in navio after the good flight so maybe dust in the barometer ? ,that day the quad raised a lot of dust

thank you

Also if i run ArduPlane,i can see altitude readings in mission planner.So i don’t know why not with ArduCopter.

gps is not conected to the board in this screenshot.

Hi, Alex
Can you please upload the onboard logs from the flight?

Hi Alex,thank you for replying.
These are from today flights.Same issues in alt_hold and displayed telemetry altitude.
Sometimes altitude was displayed but randomly and most time very inaccurate.

4 27-05-2016 (2.7 MB)

3 27-05-2016 (1.9 MB)

2 27-05-2016 (2.1 MB)

You need read these docs.

To see the logs you only need to delete the .nav from the file name and unzip.
I only want to know if altitude should show any values when connected to mission planner because in AC 3.3 i can see the values changing but im now in 3.4 rc1 and altitude is always 0 and the quad doesnt seem to mantain any altitude.
I dont know why it flew well once and anymore from that time.

Does this issue look like what you are experiencing?

Yes it sounds like my issue.
Im having problems with altitude even outside clear sky ,so maybe gps is not working properly?
How can i attach an external gps(apm one) to use it instead of onboard ublox m8n just for testing?

You have really bad vibrations and they are the reason why alt hold does not work.

Ok ,thank you for replying.
So any advise to try to reduce them? My board is fixed to a raspberry Pi case with screws and this case to the frame with doble sided foam tape.i think i have an apm antivibration mount laying arround so will try with it.

This mount works well:

Ok, thank you

Hello, I have the same issue here with arducopter-3.4dev, when switching back to arducopter-3.3 there is no problem anymore. Do you know where that could come from ?

I have an i2c range finder that is used with the i2c bus speed lowered to 400khz. Even when disabling the range finder, the issue is still present.

The altitude does change from 0.00 to -0.02 when I change the height of the drone manually by more than one meter. Using EKF instead of EK2 does not change anything

It’s a HUD issue. Once you arm, the altitude will be shown correctly.