Emlid

Community Forum

Arming Issue


#1

Hello everyone. I tried to arm my motors, but QGroundControl either says arm: leaning or arm: compass calibration. I already calibrated my compasses so I don’t know why it is doing this.


Transmitter/Receiver Issues
(Tatiana Andreeva) #3

Hi @Lucullus,

What was the quality of compasses calibration? Does the result of calibration indicate green?

sensor_compass_ardupilot_onboard_calibration_result


#4

The two compassss were in the green.


#5

When I put the transmitter’s sticks in the position for arming, QGroundControl first says arm: leaning and then occasionally it makes a mention of the compass calibration. I have already recalibrated the compasses multiple times.


(Tatiana Andreeva) #6

@Lucullus,

Could you please share the screenshot demonstrating the issue?


#8

sorry for the hiatus, I was busy with finals


#9

Now I get this error too
Imgur


(Tatiana Andreeva) #11

Hi @Lucullus,

May I ask you to disable all the pre-arm checks (you can do it in the Safety tab) and test whether it changes anything or not?


#12

thanks for your response! I was able to fix it!


(Tatiana Andreeva) #13

@Lucullus,

Could you please advice if I understand correctly that disabling all the pre-arm checks solves the issue with these errors?

May I ask you to tick them again one by one in order to understand which one causes the issue? Please try to arm after enabling each check.


#14

I was actually pretty dumb lol. I had the pi at an angle to make it fit and I just wasnt thinking lol. I moved it and it was able to arm.


(Tatiana Andreeva) #16

@Lucullus,

Great to hear it works now :slightly_smiling_face: