Following issue…
I´m able to arm the copter within the gcs and to take a flight… but it is not possible to arm the copter with a rc-transmitter only.
holding throttle to zero and rudd to the right for 5 seconds and nothing happens… tried many other combinations… nothing worked.
I have checked the channel values with cat /sys/kernel/rcio/rcin/ch3 (1-4)… the values are close to 1100 and 1900 :frowning:
barometer, compass and so on are well calibrated…
the controller is callibrated as well…
all pre flight checks are disabled in the gcs…
navio is powered through the servo rail, not trough the power module…
please help me!

Hi Maxim,

Could you please clarify which RC transmitter do you use?

I´m using a spektrum dx10t with a pwm to ppm adapter in mode 1… calibrated in the gcs in mode 1 as well


Do motors react to the joystick movements? Do I understand correctly that the only issue is arming?

Yes that is right. The only issue is the arming…
When I arm trough the gcs everything works fine and I can fly the copter.
But I do not want to use the gcs every time to arm the copter. I want to arm it without being connected to a gcs.


May I ask you to double-check you accomplish arming as described in the ardupilot docs?

Also, please also check how these parameters are configured:

Which GCS do you use?

1100-1900 range can work, but I prefer the 1000(1050) - (1950)2000 range.

Can you share a log (flying), so we can check parameters.

Few steps to follow:

Set the endpoints on your radio to approach the 1000-2000 range when performing radio calibration.

Redo the radio calibration.

Set motors param MOT_PWM_MIN at 1000 and MOT_PWM_MAX at 2000 then redo the ESC calibration.

1 Like

I´m using QGroundControl.
I think I have checked all the params.

I have changed the values to 1000-2000
Did the radio calib… then did the esc calib and they have spinned in the end…
but after rebooting it is still not able to be armed by the radio.
Flying is not possible anymore cause the props are damaged at the moment…
I could still upload the log just only spinning the motors after arming with the gcs…
This is my logfile… where I set the armed mode with the gcs
thank you for your support!
log_5_Unbekanntes Datum.bin (469.0 KB)

Some clues or ???

Your RC Tx mode is TAER (Throttle-Aileron/roll-Elevator/pitch-Rudder/Yaw).

Capture d’écran 2020-04-07 à 17.54.52

Preferred mode is AETR but it should not be the origin of your problem.

Your RC Map is not common (you use channels 2 to 5) Is it a mismatch with the PPM adapter?

Capture d’écran 2020-04-07 à 17.56.57

and Pitch, Throttle and Yaw are reversed. (Not common??)

Try to do a “standard” RC configuration (unless you cannot do that??) and report your feedback.

1 Like

Hi Marc, Tatiana!

You are totally right… the issue is the ppm adapter!
Now it works… thank you so much for the support!!!

1 Like