Arm drone without GPS - we need to be able to control the drone through DroneKit wihtout GPS

How can we get our NAVIO to arm without GPS through DroneKit?
I have tried several steps but for some reason, the solutions proposed on the drone kit website didn’t work for us:

We tried the following:

  • disabling pre-arm checks i.e. setting the pre-arm check variable to 0
  • upgrading our APM in the hope of being able to use GUIDED_NOGPS as our flight mode. However, this throws a ‘KeyError’

Our only resort is now to build from sources and modify the APM code, however, we have had problems with building our APM from sources.

Any solutions or suggestions are welcome.

Best,
ResearchTeam

I managed to reproduce the issue.

The problem was not in ArduPilot but in an old pymavlink version. Use these instructions. This should get you going.

sudo apt-get install libxml2-dev libxslt-dev python-dev this is also essential.

We added the following line to mavutil.py.
https://github.com/ArduPilot/mavlink/pull/15/files
20 : 'GUIDED_NOGPS',

And this allowed us to use ‘GUIDED_NOGPS’ mode.

We first tried to update pymavlink, but that didn’t work, which is why we changed the code manually.

Glad, you got it working.