Ardurover "No GPS" oscilattions firmware 32.1

I recently updated my Reach M+ to firmware version 32.1. I was using it in a pixhawk 4 ardurover (version 4.4.0) and it was working perfectly, but after the update the GPS periodicly switeches from “No GPS” to the real accuracy M+ has (GPS fix, RTK floa, RTK fixed etc). I am constantly monitoring the M+ on a browser and it does not “lose” the GPS coordinates, so I am guessing that the issue is in streaming the GPS NMEA via the serial output.

I have a second u-blox M9N which constantly provides the correct GPS signal.
I have also tried the M+ on a pixhawk 6C (versions 4.4.0 and 4.5.0). I have also checked the update rate to match ardurover and even tried higher.

The most important thing is that with my previous version (28.4), everything worker normally. I would potential like to downgrage using the Flashing Tool, but I can not find the zip file for firmware version 28.4 (it would be something like “”). If anyone could provide this I would be thankful.

Thanks in advance for the help

Hi Dimitrios,

We don’t recommend downgrading the firmware version, as all features and fixes are available only in the latest firmware version. You can roll back to our stable version following this guide. Please note that rolling back from Beta to stable will reset Reach settings to default.

  • Do I understand correctly that you’re following our Ardupilot integration guide for setting up?
  • Can you share the photos of your setup?