Ardurover motor problem

Hello everyone,
I am building a rover with navio2 and pi4. I am using a l298n.
here is my problem;
I am using skeed stering and ı organised my parameter with mission planner. I can get a pwm signal from my motor channel but when ı save the parameter and reboot my navio2 ı cant get a signal from my motor channels (usually ı use the 1 and 3 as recommended in the few people and ardurover documentation)

when ı armed the vehichle ı can see the my radio signal from the servo output part but ı cant get signal from navio2 servo ouput, other pwm outputs are working fine (ı did change the motor output to 4 and 6 and this time they didnt work) just my motor output wont work? anyone know why ? please help

Hi @turkishelectronics1,

Welcome to the forum!

Can you please attach the screenshots showing the issue you faced? What’s your hardware configuration? It’d be helpful to see the connection scheme and the exact make of the devices you use.

thank you for your response since there no way ı can express my problem with screetshot ı made a video about it. Can you edit my video to problem ı cant edit my problem
video link: navio2 motor problem - YouTube

Hi @turkishelectronics1,

Thanks for the video! I’ll check it and get back to you.

Hi @turkishelectronics1,

When selecting the motor1 and motor3 in Servo Output, are you configuring the SERVO1_FUNCTION to 73 (Throttle Left) and SERVO3_FUNCTION to 74 (Throttle Right) in the Full parameter list? Those are the mandatory parameters for the skid steering vehicles.

yes ı did that.

I see. I’m not completely sure about the source of the issue here, but currently, it seems related to the ArduRover itself. I’ve found the topic on the ArduPilot forum with the similar issue you described. One of the users shared possible ways to solve it, and I’d recommend trying them out.