Ardurover 3.5.1 build from sources - Main LED disabled by default?


(Pierre-Louis Constant) #1

Hello,

I have a minor issue with a custom build of ardurover 3.5.1 from source: the main led on the board appears to be disabled.

Compared the parameters from the emlid provided ardurover 3.4 (with which the status LED is functional) with the new build and that dos not appear to be related.

Any idea ?

Thanks in advance,
PLC


(Tatiana Andreeva) #3

Hi @plc,

Have you tried to run the LED example? Does it work?

May I ask you to post the screenshot of Emlidtool as well?


(Pierre-Louis Constant) #4

Hello @tatiana.andreeva ,

Yes the LED is functional. LED example works.

The LED also works through the emlidtool (version 3.4) and when launching the service manually.

Version 3.5.1 cloned from the ardupilot git, compiled with
./waf configure --board=navio2
./waf --targets bin/ardurover

is the one that causes problem. (and not using emlidtool for this version, launched manually, and confirmed as otherwise working with a GCS)

Thanks.


(Tatiana Andreeva) #5

Hi @plc,

Could you please try to download ardurover pre-built binary and check whether the same LED behavior remains?


(Pierre-Louis Constant) #6

Hi @tatiana.andreeva,

As a matter of fact the 3.5.1 prebuilt has the same issue, started manually as usual, the core program works but the LED is non functional.

Interesting.

Let me know if there is anywhere I can dig at my end.

Thanks


(Tatiana Andreeva) #7

Hi @plc,

I’ll try to reproduce it and get back to you with updates.


(Tatiana Andreeva) #8

Hi @plc,

I’ve tried to run ardurover 3.5.1 on Navio2 and faced the same issue you described. We’ll consider that in the Navio2 next image.

Currently, I’d recommend reaching out with this question to ArduPilot forum or GitHub.