Arduplane service not starts

Hi guys,

I’m trying to set up my raspberry PI following the instructions present in Navio2 documentation.
Here the steps I achieved:

  1. Downloaded and installed succesfully “emlid-raspbian-20200922.img.xz” image
  2. Set up of wifi connection and log in with putty
  3. SSH into raspberry and typed: sudo emlidtool ardupilot
    –> Here I selected: vehicle:copter; version:4.0; frame: arducopter; enable on boot and start service.

The problem is that the service does not start (picture below). I also tried to enable manually but the situation did not change.

One other important thing is that I’m only working with rasperry PI connected, and NAVIO2 is not connected at all. Could be this the cause of the issue?
I believed that at least the service could be started…

Thanks for the answers,
Marco.

Hi Marco,

Welcome to our forum!

Yes, this causes an issue indeed. You need to attach Navio2 to Raspberry Pi to make it work. Without Navio2, the emlidtool can’t start autopilot.

You may take a look at this part of the guide that explains how to mount Navio2.

Thanks,

it worked. The service started and now I can also estabilish communication with Mission Planner on windows.

An other think that I want to ask: Ardupilot is saying me that I shall update firmware but as I understood correctly, this operation should be done using UART communication. How can I find the pin-out to attach RX,tx and gnd to my board? And what’s the baudrate?

Thanks again,
Marco.

1 Like

Marco,

Do you get this message in Mission Planner? If yes, you can skip it as there should be no issues with using the currently supported versions of firmware by our image.

Nevertheless, you can install newer versions of ArduPilot autopilot by using the instruction in the following guide.

You can check the scheme in the Pinout guide. The default baudrate is 57600.

Yeah, sorry… I meant Mission Planner says me…

However, also if not needed i’ll check the link you provided me and thanks again for the pinout shared.

Greetings,
Marco.

1 Like