Ardupilot doesn't see the position

Hi! Has anyone solved this? I am having the problem that ArduPilot is not receiving (or interpreting correctly) an NMEA stream on UDP. The input is specified with -E udp:, although I believe udp: should work as well?
TCP doesn’t work either. GPS_TYPE2 is set to 5. I tried with first GPS as well, but whatever I try nothing arrives in ArduPilot!
Advice is much appreciated.

Hi Klemens,

Welcome to the community forum!

Let’s try to solve it together. Before starting our investigation, though, we will need to see the full picture of what you’re trying to achieve and what you get. That’s why I’ll ask you to give us more details here.

It’ll be easier to follow our template as to not miss anything. Please share the following:

  1. Image and ArduPilot version.
  2. Detailed problem description. How does observed behavior differ from the expected one?
  3. Your step by step actions.
  4. Picture of the setup and connection scheme.
  5. If using any additional hardware please provide exact make and model.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.