Arducopter 4.0

Arducopter 4.0rc1 is available for beta testing.
https://discuss.ardupilot.org/t/copter-4-0-0-rc1-available-for-beta-testing/48545

You can find a compiled version in the Firmware repository, but it need some new components not available in the latest Emlid distribution (20190227).

If you compile the source (GitHub) on your Pi, it will work.

https://docs.emlid.com/navio2/common/ardupilot/building-from-sources/

OneShot125 ESC mode is still broken (since 3.6.0).

2 Likes

Hi Marc,

Thanks for the update!

It’d be interesting to hear about the results of the testing :slight_smile:

Hi!

I just had a short flight (windy day) with it. Quite stable in stabilise flight mode or AltHold mode.

Oneshot 125 is still out of service…
Led light is Green at startup but goes off after.

If in
/boot/config.txt I comment
#dtoverlay=navio-rgb

Navio2 Led stay green…

I tryed to change Led settings in Mission planner with the same result: Led go green at early startup then goes and stay off.

1 Like

Led sequence is ok with Arducopter 3.6.11

With the same settings, Led is OFF with 4.0rc1

My Navio2 is flying with 4.0rc2.

I changed from a flat Hexa to an Y6.

Led problem is still the same.

Oneshot125 is still off.

Save waypoint and Auto mode are fine: I saved 4 wp and performed the same pattern twice in Auto.

RTL is fine

Here is the link to the log

https://www.dropbox.com/s/wbs94n74w7ju4pb/2019-11-06%2013-49-39.bin?dl=0

So far, all is ok for me but I need to have Oneshot125 working before updating my Octo with Low KV motors.

Just had my 3rd flight with Arducopter 4.0-rc. Firmware was built on my navio2. Up to now everything o.k. except:

RTL and SmartRTL are not working. Switched to RTL via CH7 and copter seems to go to some kind of AltHold mode, drifting away. Same happens when battery FS enables RTL or SmartRLT.

What could be wrong? Logfile download here: https://1drv.ms/u/s!ApiUq3GzWBaikkl53japmRVYmmQa?e=mP7AL4

Thanks for you hints!

Felix

p.s. also LED only lights up green on startup on goes off afterward all the time.

Bonjour Felix,

I had a look at your log. RTL was triggered by Low battery There is an error msg . You could lower this voltage to avoid false failsafe. On low battery, failsafe action should be LAND. You are not sure to have enough battery to climb, return to home then land.

RTL parameters (your RTL altitude is set à 5 meters, quite low as default is 15m)

Here is a link to my flight log today: https://1drv.ms/u/s!AlTaMbgj9DGH4GYZO2fTkPHJlCSb?e=qocedO

RTL parameters are default.

There is a small 4 point navigation, some guided mode and a commanded RTL. On my settings, RTL is a flight mode as Loiter or AltHold. It is triggered by channel 5, not a separate switch.

I didn’t test smart RTL.

I confirm the Led off after initial boot…

Marc

Hi,

I had another look at your parameters. Can you confirm you have Lidar or another range finder on board?

There is also an Altitude anomaly, maybe relative to the Range Finder rmk:

My flight:

It could be the cause of the RTL problem.

Marc

Hi Marc!

Thank you for your valuable and prompt investigation! Here some more background information:

  • Yes, the drone is equipped with a lidar light V3HP. Primary altitude source is set to range finder. As you can see from altitude measurements, I was flying at relative low altitudes (typ. 1m) above ground. The drone altitude follows nicely the terrain with high accuracy at stable altitude, which would be impossible by using the baro as height source.

  • There is a second range finder pointing upwards. Proximity is activated so that if the drone is close to a ceiling it keeps a distance of 1m, regardless of any throttle increase. The measuring range of this range finder is limited to 12 m. You can see both range finder data in the PRX menu. Strangely, in the new mission planner, the date of both range finder are overlayed in one graph (checking DIST). In the RNG menu I get just data for “Down” but nothing for “Up”. Maybe you can confirm that?

  • further, I have a Optical Flow installed. But as you can see, in the this flight, it was not activated for PosHold. I used GPS information.

  • The battery low failsafe parameter has been set intentially to a relative high voltage, triggering RTL, so I could test a failsafe event after about 10 minutes flight. As explained before, reaching the battery failsafe, it triggered some undefined “flightmode”, where the drone stopped to react to my RC-transmitter commands, just drifting slowly away. I had to switch from PosHold to AltHold to gain again control. Actually I do not understand, why a failsafe trigger is labeled as an error?

  • Also I used channel 7 to switch to RTL manually, which caused the same reaction like discribed above.

  • Earlier to this experiment with FW4.0.0-rc, I was using the arducopter FW 3.7-dev and RTL and Smart RTL were working well. I tested several RTL-altititudes from 5 to 50 m and all were exactly attained.

So I’m still in the dark…

I have no experience with Range finder and optical flow…

As RTL could be dependant of baro altitude, it may be interesting to do your test at 5 meters or more. During your flight, baro altitude was below 0 most of the time. So when RTL is triggered, it stay below 0 (consider itself on ground and drift??).

Next flight, I will test smart RTL. Next Friday due to high wind and rain…

Yes Marc, you have a clue! That could be the reason. I’ll test it as soon as possible! Although, if range finder is set as the primary height source, this could be considered as a bug in the FW.

Thanks and good night.

Felix

Hello,

Smart RTL was fine today. It follow path and altitude variations.

I noticed baro glitches, I will check at next flight. There were loose screws…

Hi Marc,
thanks for your reply. My smart RTL now works too. Updating to arducopter 4.0 I had messed up with some parameters which I corrected now.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.