Arducopter 3.5rc1


Did you have a try with Arducopter 3.5rc1 for Navio2 (from

I did a new setup based on 3.4.4 latest ROS image and arducopter for Navio2 3.5rc1

I selected Hexa frame, X configuration, did the Radio, Accelerometers, compass calibration.

When connected to the PC, without battery power, all seems normal, Not armed PWM is at 1050, armed PWM are also correct at Min around 1150.

So I went to the field for first flight.

TX is On, Battery plugged, Navio boot seems ok but as soon as ESC are initialised, bad shit is coming:

ESC are delivering erratic power to the motors (not armed). Not enough to fly but quite disturbing and unconfortable to unplug the battery. No damage (I was lucky).

Back at the bench, without propellers and a with smaller battery, the defect is confirmed.

I revert back to 3.4.4 (SDcard swap) and ESC output is normal.


My guess. And it is a guess. 3.5 introduces major changes with how frame types are handled. Likely still needs work on Navio. I am sure one of the Emlid guys will chime in here. Glad you were able to abort without damage.

Thanks for testing it out. We’ll try it out tomorrow.

First guess, have erased old parameters from AC-3.4.4? AC-3.5 will incorporate a lot of changes and I suppose that something might be a little awry now (it’s now almost aligned with the latest master branch which in discouraged to fly off).

Could you describe how did you launch the newest AC? I hope you’ve gone through the beta-docs and launched it like described in here!


As there is some ?? about the change, I redid the settings (latest Mission Planner ß), reset to defaults (3.5 rc1) and redid the configuration (frame choice, calibrations, and also ESC calibration). Esc are OK at the end of calibration but next boot with battery give same problem (erratic motor activity). RC out stay at low -no variation but motors are running…

Now, power module is dead, (only 2.7 volt out…) so no boot (no more problem) :frowning:

Pi config and Arducopter settings are by the book,


ExecStart=/boot/arducopter $ARDUPILOT_OPTS


ARDUPILOT_OPTS="-A udp: -C /dev/ttyUSB0"

I will revert to 4.4.4 card with a spare power module and wait a debugged version.



i didn’t try 3.5rc1;
but after resetting parameters in missionplanner and then rebooting pwm out is at 1100 and my motors spin too - until i calibrate my transmitter (if i remember correctly);
not sure if this is related to your problem (actually i don’t really think so)

@george.staroselskiy What can I help test? I finally had time to build another copter we can keep around the shop for testing/crashing. Right now we are running latest beta and it’s working well. If you can let us know about when next beta will drop I can plan a bit better to help test.