Arducopter 3.3.3

Hello,
I have bought the reach Kit and the version of the arducopter firmware that I have to use needs to be 3.3.3 (pixhawk flight controller) and I can’t neither change the firmware nor implement the ERB protocol.
Is there any way that i can still make the RTK work on my multirotor using the NMEA protocol? If yes, what are the settings that I need to use to make it work?
Up until now I setted the system into another flight controller (also Pixhawk) with a 3.4.5 firmware using the ERB protocol and with that firmware everything works just fine, so I know that the settings that I’m using are correct.
I have tried to use the same settings with the Reach and Reach RS but wth the 3.3.3 firmware, with the only difference being the change from the ERB protocol to the NMEA one, but it didn’t work.
Could you please give me an explanation? is there any solution for my problem?
Thanks to all

AFAIK NMEA will not let you inject RTCM data, so it will not work.
Have you tried to configure Ardupilot to inject RTCM data ?

I strongly advise you to use ArduCopter 3.5.5 a lot of ERB bugs have been fixed in that version.

No, I haven’t tried that. Could you please explain me how to do it?
Unfortunately I have to use the 3.3.3 version and can’t update to newer versions.

Google is your friend:
https://docs.emlid.com/reach/ardupilot-integration/
http://ardupilot.org/copter/docs/common-reach-rtk-receiver.html

If it does not work, either:

  • update to 3.5.5
  • or fix the source code of 3.3.3, recompile, and upload it.

In theory, you can use NMEA. However, ArduPilot seems to interpret incoming NMEA stream as a misconfigured u-blox chip. At least, by default. You might find the right configuration for this, although I can not really help with this.

Your best bet is to use newer ArduPilot, of course.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.