Hi all.

I am new to Navio and Raspberry Pi. I installed the image from the emlid website, and when I went to run “sudo apt-get update”, I get the error:
E: The method driver /usr/lib/apt/methods/https could not be found. N: Is the package apt-transport-https installed?

When I ran “sudo apt-get install apt-transport-https”, I received the exact same error. I have checked my sources.list and sources.list.d files for syntax errors and for sites that redirect to https, and am still having the same issue.

I am connected via a school’s ethernet.

What should I do?


This is what I’d try first:

  1. Backup lists
  2. Change https to http
  3. Then run sudo apt-get update
  4. Run sudo apt-get install apt-transport-https
  5. Restore from back and sudo apt-get update

The second option would be installing the package manually with dpkg -i.

Guesswork: is https_proxy environmental variable has been modified? I reckon you might be behind a proxy in your school.

I followed your suggestions, and when I did so, I still had the same issues.

None of my sources had an https typed out, but only http.
When I run sudo apt-get update, I still get
E: The method driver /usr/lib/apt/methods/https could not be found. N: Is the package apt-transport-https installed?

sudo apt-get install apt-transport-https gives me
WARNING: The following packages cannot be authenticated! apt-transport-https Install these packages without verification? [y/N]

If I say yes, then I receive,
E: The method driver /usr/lib/apt/methods/https could not be found. N: Is the package apt-transport-https installed?

When I use the dpkg -i method, I get the errors:

dpkg: error processing archive http://ftp.us.debian.org/debian/pool/main/a/apt/apt-transport-https_1. cannot access archive: No such file or directory Errors were encountered while processing: http://ftp.us.debian.org/debian/pool/main/a/apt/apt-transport-https_1.

What should I do now?

What exactly have you entered when you’d tried the sudo dpkg -i method?

sudo dpkg -i http://ftp.us.debian.org/debian/pool/main/a/apt/apt-transport-https_1. ?

This would definitely not not work! Take a look at this post to understand the difference and the relationship between the two utilities. In short, dpkg -i is a backend for more sophisticated apt-get that can resolve dependencies and so on.

So, in order to make the latter method work you need to get the package first and then install it with dpkg -i.

wget http://ftp.us.debian.org/debian/pool/main/a/apt/apt-transport-https_1. (where did you get this URI, by the way?)
sudo dpkg -i apt-transport-https_1.
These should do. If this doesn’t work, either, please post what kind of error gets written.

Thank you for your help. I actually had attempted the wget option and it originally failed. I took the Pi to another ethernet connection (different from my school’s network), and it worked no problem. All is well for now.


I’m a beginner for Raspbian. When i tried to enter the command “apt-get updates”, the Pi requested me to install the “apt-transport-https”. When i attempted the following command “apt-get install apt-transport-https”, it requested the same error. And i don’t know on how to change the https to http. Can you show me the steps to install the apt-transport-https?

Could you please provide us with the information about your setup:

First off, I’m interested in the output of this command uname -a.

Thanks workd