APMNavio + Python-Picamera bricks my Pi 3

Install Navio Image, Enable picamera using raspi-config, install python-picamera, install apm-navio.
Pi won’t reboot, Green LED flashing 7 times.

I have exaclty the same setup on my Pi2 (without the navio board plugged in) and it works fine.

Any ideas?


that usually happens due to misalignment of the camera’s ribbon cable!

Still having issues. Now I get no RCInput on Mission planner, but the python scripts can detect all channels.

in missionplanner - flight data window - status tab:
can you see the rcin channel’s input for the various channels correctly?

No. When I try to calibrate there is nothing displayed on the “slide bars”. I’ve disconnected the camera and started with a fresj SD card image. It was working fine before i fitted the camera.

try starting arducopter without any other python scripts!

I’m not running any Python scripts. Tried uninstalling python-picamera. Still no RC input on Mission Planner

There’s a new thread on this topic. I consider the initial issue solved and close this thread.