APM intergration


I am trying to do the APM intergration with the reach. I’ve got the problem that when I want to: “Configuring Mission planner to inject RTK corrections into telemetry” (this is the last step) and eject GPS, that he can’t connect to my base.

When I enter the IP of the base and the port of it I get the message “error connecting”. After this, a message still pop ups to put in an ip address and a port.

I checked the ip and the port and I can get in with my pc.

Could someone help me to solve this problem or knows why I get an error while connecting?

Thanks in advance


How is your base Reach configured? Are you in the same network?


Yes I was in the same network. I rebooted the system and tried again and after I did this it worked.

Only when I wanted to test the total it didn’t work, I recieved GPS sats when I looked at my RTK self but didn’t see anything on mission planner. He said I had no sats. This is maybe caused because we use erle brain 2 instead of navio +?


Hi Jeroen,

I don’t know if erle has included support for ERB protocol that Reach uses. You should try asking on their forum about it, here is the relevant pull-request.