APM beta-testing

Nice!

I will install this version for flight testing this week. I will get back with results as soon as possible.

Alex

Thanks very much for this updated release. I indeed flew my quadcopter this morning : it fell off the ground while in “alt hold” mode just after having a “compass variance” issue. Result is the my landing gear is broken…
After installaing this new package, when I perform the live calibration in mission planner I got 2 compasses being calibrated instead of only one previously.
Here are my offset values:
Compass 1: -217 -31 -224
Compass 2: -315 -333 59

Indeed it only changed the error messages I am getting from my navio. I now get in circles the following messages:

  • PreArm : error Pos Vert Variance
  • Bad AHRS
  • Inconsistent compasses

Of course I have put some fabrik on top of the barometer and there is no wind flowing into it…
I really start to worry about my navio board quality. It has been several weeks I am performing different tries of configurations (Rpi2/Rpi3, last EMLID disk image, stable and beta versions of APM…)
Isn’t possible that one of the compass on my navio is dummy?
I am using very standard PPM radio and 3DR telemetry. There cannot be big inteferences as they are located quite far away from my board (I can send picture if necessary)

Thanks for your help, I think I will drop my navio outside the window …

Guillaume

@Guiboy

We’re very sorry about the gear. But let’s get to the bottom of the problem!
It’d be very helpful if you provided us with logs to analyze. Have set primary compass to the second one and rotation to ROTATION_ROLL_180? Inconsistent compasses error is usually because of the wrong rotation.

Thanks for the reply, here are is my dataflash logs2016-05-02 14-52-07 9.bin.nav (2.1 MB)

Sorry for the file extension i had to rename it to .nav manually to fit the forum Policy.

thanks very much for anything you Can do

Is this build from the Emlid github repository (navio-experimental branch)?

I have to compile in some extra code and don’t want to use the ardupilot master branch.

Dale

Looking at the forum threads it seems having an external compass added to Navio 2 often solves this issue. I am not fond of adding unnecessary hardware onto my quadcopter but if this is an additional security to avoid my drone falling from the sky like a stone I would buy one.
What is the preferred reference/product in terms of reliability for the price ?

Additional topic : my GPS fix seems to randomly perform. It sometimes get very good signal quality within seconds, sometimes it just doesn’t get any fix. Maybe this is linked to my compass issue?

Thanks for the infos
Guillaume

Bonjour Guillaume,

I think that people were having issues with the internal compass, so they tried to use an external one… but this also had issues… this seems to have been fixed in the beta software referenced above.

As for the GPS, does it take some time to get a fix or not getting a fix at all? It could be that the GPS will take longer to get a fix (cold start) after sitting for a while with no power… once its been powered for awhile and has a fix, restarting the GPS will get a fix faster (warm start) as there are super caps holding a charge for the satellite almanac data.

Dale

Thanks Dale for your reply.
It seems my GPS is randomly working. Even though I may have 10 sats and a GPSHDOP of less than 2, it seems to struggle to get the “3D FIX”. It happens I get it before arming and lose it in flight.

It still get “inconsistent compasses” error, by the way I did not see how to change the “rotation” parameter mentioned by staroselskiy : this option can apparently only be activated in mission planner for external compasses. Quite obvious to say but I suppress this error message by de-activating the second compass… and I get “error compass variance” errors instead while in flight.

Well, to summarize the situation:

  • I am running RPi3 + Navio 2 + Beta version of APM (the latest release pointed in EMLID docs quoted as solving the compasses/EKF issues)
  • When I initialize my quad with only one compass, everything seems to be working fine, pre-flight checklist ok (but “inconsistent compasses” if activating the 2nd in-board compass)
  • During flight, I get “error compass variances” and “bad ahrs” messages. Alt Hold and Loiter flight modes don’t really work (glitches in altitude)

And last but not least, it seems my APM crashed during flight as I could not recover stabilize mode. I had to hover on top of me until the battery was so low the cut-off mode of my ESCs had to activate. Rpi + Navio 2 doesn’t seem to be a robust set-up…
Last action I imagine : install a Rpi Case with dampers (I am using soft foam but it might not be the perfect way…)

I had another try this morning, here is the log http://dl.free.fr/eXItSndEJ

Please someone help me…

Thanks!
Guillaume

This because you did not set orientation for the compass. Please see the correct configuration here:

For now you need to enable it as external, that will be resolved with next release (there are some dependencies in APM code).

Hi, Guiboy.

  1. You have catastrophic vibration!
    Please, read the recomendations and these and these.
  2. The second compass is not installed properly. The axes do not coincide. If your external compass is in a non-standard orientation, you must manually select the orientation in the combo box.

Thanks very much for the quick and detailed support.
I re-calibrated my compasses as external ones, one with rotation “none” and the other as “rotation 180”.
This has solved the “inconsistent compasses” issue. Thanks!

I modified my set up using silicon dampers, which seem to really have improved the vibration level as seen in my last dataflash log http://dl.free.fr/vUx0mERKf
But it seems I still am on the allowed limits and get some not null values on clip 0 (around 20 for a very short flight).
I think I can still improve a bit.

In the meantime I had some “err. pos. vert variance” messages, I assume this is again coming from vibrations in the X axis (vibration peeks on X axis correspond exactly to clip 0 events)
I know what I have to do… wait for some weeks that I finally receive some additional dampers for more increase stability. So looooong.
I did not find any proposal for 3D printed cases incl. vibration damping on EMLID docs. I think this would be definitely worth for you to sell anti-damping cases for RPi+Navio as it seems to be a must for good flying conditions. Having a good hardware set-up is not so evident

Thank you!
Guillaume

Check this out Anti-vibration mount for Navio

1 Like

The solution that worked for me, is to disable “obtain declination automatically” in the compass setup screen and enter the right value for my location by hand.

Thanks sebastian I will try it next week when I can go again in flight. What do you mean by this déclinaison value? Where can I get this value? Sorry for my newbiness…

The magnetic field is not homogen all around the world. Because of that, the angle between true (geographic) north and magnetic north is different depending on where you are on the globe. That is magnetic declination.
In missionplanner on the compass setup screen is a link to a website where you can get the declination for your area.

1 Like

This is crystal clear sebastian, thanks

I’m not able to run Mission Planner as I do not have a windows box. On Linux I’m using APMPlanner 2.0.19v-rc5. I don’t have the same GUI options as shown in https://docs.emlid.com/navio2/Navio-APM/installation-and-running/#second-compass-configuration.

Here are the options I set to get it working, after tinkering with a while longer than I care to admin.
COMPASS_EXTERN2 = 1
COMPASS_ORIENT2 = 8
COMPASS_PRIMARY = 1
COMPASS_USER2 = 1

Do a recalibration and should be good to go. Hope that helps someone!

1 Like

I would like to say great work to everyone at Emlid, I have been configuring my s1000+ frame from a pixhawk setup to RPI 3 and Navio2. I noticed at the bottom of the APM page in documents there is a disclaimer about auxiliary options…

WARNING Auxiliary function switches on channels 5-8 are still not supported and could lead to erroneous PWM generation on motors’ channels and that’s why we do ask to NOT SET AUXILIARY FUNCTION SWITCHES TO RC5…8.

Does this mean rc channels 5-8 or the pwm outputs 5-8 on the navio board? I have 8 motors so my avalable auxiliary outs start at 9 to 14. Can I still setup camera trigger from my transmitter channel 7 and connect it to pwm 9?

@Nikker it’s about the outputs, feel free to use outputs 9-14 for auxiliary function.

Thank you, since I’m running octa it seems like it’s not an issue for me.