Android ground-station connection

Hi, everyone! This is what I have in my arducopter file:

TELEM1="-A udp:"
TELEM2="-C udp:"
#TELEM1="-A tcp:"

#Options to pass to ArduPilot

— Where is my phone’s IP address:

I then open the Tower app and configure it for udp connection, with UDP Server Port 14550:

After pressing “connect”, I am connected to the drone:

I can see I’m connected, I can see my location and my drone’s flight mode. But I cannot see my drones information (roll, pitch, yaw, velocity, height, battery information, gps location etc). I cannot arm my drone through Tower either.

Why does that happen? I have access to all these information when connected through Mission Planner. But because my goal is to use Tower’s “follow me” tool, I need it to connect properly.

Thank you.

I had the same problem with Tower, while Qgroundcontrol worked without a problem. I suspect it is a bug in Tower.

In my case, QGroundControl doesn’t work either =(
It even gives a warning message:

I have also tried tcp connection, where I have on my copter file:

#TELEM1="-A udp:"
TELEM2="-C udp:"
TELEM1="-A tcp:"

#Options to pass to ArduPilot

I got my copter’s IP through the command “hostname -I”:
pi@navio:~ $ hostname -I
pi@navio:~ $

So I set the options for TCP on Tower as
Server IP:
Server Port: 6000

I then push “connect”, but it never connects:

I’m not able to connect to Mission Planner through tcp either.
On QGroundControl I can’t seem to find a place to change the desired connection protocol from udp to tcp. Does it have this option?

I’m using a Samsung Galaxy S5, with Android 5.0.

Today I tried it with my friend’s phone, a Sony Xperia E4 with Android 4.4.4. It worked flawlessly.

The problem is I can’t keep asking for someone else’s phone every time I need to fly. So would anyone have any suggestions? =/

Tonight I tried having my phone and drone connected to my home Wi-Fi, instead of connecting my drone to my phone’s mobile hotspot. I changed my android’s file to include my new IP address accordingly:

And. It. Worked. Somehow.

So it only accepts a certain type of network/IP? How do I make it also work with my phone’s mobile wifi?

I can’t keep depending on another network to be around, not to mention I would have to open my arducopter file to change its IP address every time as well.

Thank you.

Anyone? =(

This topic was automatically closed after 100 days. New replies are no longer allowed.