Android can't download logs

I tap the download icon. It gives the name of the zip file. I tap “continue”. Screen returns to “Logs”. But I can’t find the zip files to work with them.
New user.
Android 12

Hi @richhensley63,

Welcome to the community forum!

Can you first double-check that the app can access your internal storage on the phone? If not, I suggest allowing it and then trying to download the logs once again.

After a long time (many minutes, if not an hour), a notification on my phone said my downloads failed. I just allowed all permissions for this app, including “Files and media”. Tried another download. It’s been several minutes, but no response from my phone.

Did you try over Reach Panel?
It is worked on me

It appears that Reach Panel is for Reach RS/RS+
I get a similar, but different, screen with Reach RS2

Thanks anyway

Hi @richhensley63,

Reach Panel is a web interface that’s available for all of our devices. You can access it by holding the receiver’s name for a few seconds in ReachView 3 and then choosing the Reach Panel option. However, the Logging tab actually works with the tab from Reach Panel anyway.

I suggest accessing the receiver in Reach Panel through your PC. For that, just type in the Reach’s IP to the address bar of any internet browser. Your PC should be connected to the same Wi-Fi network as Reach. In case you’re using Reach’s hotspot, the IP is

Let me know how the downloading goes now. What firmware version is installed on the receiver?

Polina, thank you for your help. I still couldn’t get the Android app to connect correctly to RS2. All attempts to download a log failed. I think it might be an issue with Samsung.

I then tried with an iPhone, and the app worked correctly. I will use it from now on. I also learned to connect my pc to the RS2, and download that way.

Since the problem with my Android was not solved, I think this whole thread can be deleted from the forum.

Thank you.

Try installing a third party file manager app. I had to do that with my phone. Something like CX File Explorer. Choose that app when you’re in the export panel and see if you can complete the file saving from there.

I’m not sure this is an Emlid issue more than a proprietary phone OS image issue.


Thanks Gabriel, but I did have CX File Explorer on my Android. But when I pressed the download button in the Reachview panel, it didn’t respond with a choice of how or where to download the zip file. I only got a choice between “Save to Downloads” and “Cancel”. “Save to Downloads” gave me a brief popup saying “Download Started”. Sometimes, many minutes later, I would get a notification saying “Download Failed”. Other times, nothing. A search in CX File Explorer app, My Files app, and Windows Explorer (after connecting to pc), all turned up nothing. I have now switched to using an iPhone.

1 Like

Hi @richhensley63,

That’s definitely not how we want our app to work. But it looks to me like I need to agree with Gabriel: it seems an issue with the phone’s system. However, if you can elaborate on the model, we can try to reproduce it to check.

Meanwhile, you can use Reach Panel to download the logs. As the iOS works just fine, you can indeed stick to it.

Hi Polina. After using an iPhone for a week, I tried one more time with my Android. And this time it worked. I don’t know why the App wouldn’t connect correctly before. There may have been a Samsung or Android update during that time, which reset my Wi-Fi or data settings. And somewhere in those settings was my problem. This thread can be closed. And since my original problem remains unknown, I don’t think this thread can be a benefit to anyone. If you can, I think this whole tthread should be deleted.
Thanks again for trying to help. I have a couple more questions. But for those, I will start a whole new thread.

Hi @richhensley63,

It’s always a good idea to create a separate thread for a few unrelated questions. You can also contact us at with them.

I’ll close this thread. If you ever come across this issue again, please start a new topic here on the forum. It’ll be essential for us to know the model of your phone/tablet and the OS version, the firmware version on your Reach device, and whether the issue is repeatable through the Reach Panel.

1 Like