Android 13 and RV3

Any one else having issues with accessing RV3 (latest update:7.9) on the RS2 (ver: 29.2) after the update to Android 13 this past week? On my Google Pixel 4a, it displays the receiver as being available but gets stuck in trying to connect to the unit, and ultimately I get a message saying the connection to the receiver has been lost. No problems with connecting to RS2 via iOS or using Reach Panel on the Android.

1 Like

Try disabling bluetooth and mobile data. It’s not guaranteed to change anything, but this is suspiciously similar to what happens to my phone. It’s not Android 13 but your symptoms are exactly the same.

2 Likes

Have you tried forgetting all network connections on the device and the receiver? Sometime my receivers get stuck in limbo so I have to go somewhere with no WiFi signals that are in memory so I can get to the Reach hotspot.

What @Gabriel_C is saying is what happened to all our devices when 12 came out except for the fact that it would kick you out of the app as well. I had a weird issue this morning with all the flight apps we use with a DJI Air 2S and everything kept crashing back to the home screen. I then realized I didn’t have any of my mobile data devices running. I wouldn’t think any of these apps require data. I’ll try to replicate soon.

Where did you get 13 from? I have a Google Pixel 6 Pro and no updates are available. Beta?

1 Like

Hi @lucas,

Just wanted to second suggestions of Gabriel and Michael. Did you have a chance to try them?

Thanks for the suggestions. Indeed, forgetting the RS2 hotspot on the Android 13 and reentering the credentials seems to have solved the problem with accessing RV3. I also tested the connection using the Android 13 hotspot to the RS2 and this works now as well. I will test at a later point using Bluetooth in the field to see if any issues arise with the BT connectivity.

For Android 13, it seems to be a phased launch. It was available immediately upon release for my Pixel 4a.

4 Likes

@lucas,

Great news! Thanks for keeping us updated.

I installed Android 13 on Sunday and it has run fine for the last two days. I would say it is an update authentication issue and not A13 itself. I am sure I will have to do a credentials reset in the near future. It just seems to be part of using Android with Emlid.