Alt Hold and Loiter don't takeoff

Hello,

I have had no problems flying my drone on Stabilize mode. Today, however, I tried Alt Hold and Loiter on two situations:

  1. Started flying on Stabilize and switched to Alt Hold or Loiter.
  2. Tried to takeoff directly in Ald Hold or Loiter.

On situation 1, my drone’s motors would lose rotation speed and descend until I switched back to Stabilize or landed.
On situation 2, my drone wouldn’t even takeoff. I would put my throttle stick at 100%, but still wouldn’t be enough for takeoff.

Would anyone have a hint on how to fix this?

I would like to notice I have changed my MAX_VEL_Z parameter to the 20cm/s minimum for safety issues. I don’t think that’s the problem though, given I can perfectly fly it on Stabilize.

Thank you.

Hello,

There are some possibilities, but we need a log to help you.

1: When flying in stabilise mode, what is the position of your throttle lever? It should be at neutral position to maintain altitude when you switch to Alt Hold or Loiter.

http://ardupilot.org/copter/docs/ac_throttlemid.html

2: ??? log needed…

Marc

Thank you,

My throttle lever on stabilize isn’t on neutral, as I have not set it up yet. What I would do is push the lever to neutral as soon as I switched flight modes. I realize this isn’t efficient.

I will get the logs tonight and post them here =)

So, yesterday I had a few flights, and I disarmed and armed the motors back again to make sure I had different logs, but apparently I only got one.

Situation 1 - Changing flight mode during flight: Log below shows the throttle output quickly decending after I switched from stabilize to alt hold, on line numbers between 19 and 25.

complete log: 2017-11-27 18-06-45.tlog (113.4 KB)

I’m not sure if this helps much. If there’s anything I should do to enable a better analysis, please let me know. My flight locations are a little limited, but I’ll be flying again tomorrow night.

I just tried taking off straight from Alt Hold and Loiter modes (as described in situation 2).
What I did: turned the drone on, switched to Alt Hold, armed the motors, increased my throttle stick from 0 to 100% then back to 0%. Then switched to Loiter, incresed my throttle stick from 0 to 100% then back to 0%,

I could see the motors velocity increase a little bit, but not enough for takeoff. The drone never took off.


2017-11-28 22-40-07.bin (399.2 KB)

Hello,

Significant log data is RCin3 (Throttle) and RCOU 1 to 4 (Motors).

Can you have a look at the same graph when flying in Stabilize mode. Your tlog file is not usable to have this data.

MAX_VEL_Z parameter: I have no reference to such parameter.

Your firmware version is 3.4.6. You can update to the latest from Emlid.

Marc

I just updated it with:
sudo apt-get update && sudo apt-get dist-upgrade

I did notice there are 2 images on the navio2 webpage now: Stretch and Jessie. What are their differences? Should I re-install my disk image, or does the update commands get the job done?

I’ll be flying later tonight and post my results. Thank you for your time! =)

Sorry, I got its name wrong… The parameter is called PILOT_VELZ_MAS, and it’s set to its 50cm/s minimum

OK,

Please, can you change it back to 250 (default). As there is also PILOT_ACCEL_Z whith the same range (20-500) it may be a source of conflict (guess??). If happy (AltHold and Loiter OK), you should try to reduce both parameters to reduce the vertical speed and acceleration.

Wiki say:

PILOT_SPEED_UP: Pilot maximum vertical speed ascending
The maximum vertical ascending velocity the pilot may request in cm/s

Range Increment Units
50 - 500 10 centimeters per second
PILOT_ACCEL_Z: Pilot vertical acceleration
The vertical acceleration used when pilot is controlling the altitude

Range Increment Units
50 - 500 10 centimeters per square second

Latest Emlid is Stretch image…

Marc

I set the parameter back to its 250 default.

I was able to takeoff, but after a few seconds the aircraft would slowly go down and not go up again, even with my throttle stick at 100%.

2017-11-29 21-22-05.bin (1.3 MB)

Here is a video: https://youtu.be/XPizA6tfyos
Video description: I took off on loiter mode. After a few seconds in the air, the drone started to go down until it landed without my wish. At 0:36 you can hear the motors spin faster: that’s me putting my throttle stick at 100%. Given it didn’t take off again, I gave up and disarmed the motors.

Should I be concerned about the “EKF2 IMU0 fround mag anomaly” on the log file?
Which height measures should I check my log for in order to see if it also shows the drone decended?

I also wanted to try and see if the problem was that my throttle mid lever is not set (my log shows that I hover at a 27% throttle on stabilize). But I didn’t find the variable I should change in order to modify the throttle mid, as I have stated here: Throttle mid too low

Hello,

Can you do a flight only in stabilize mode and post the log. Do not try loiter or alt hold.

There is a problem with the RCOut. Need to check how it work in stabilize mode.

Marc

Sure. This log cointains 2 moments in which I was perfectly flying on stabilize:



2017-11-29 09-54-47.bin (3.5 MB)

Not easy,

All motors got bad PWM signal… and I do not know why.

Can you have a try with latest Emlid Stretch image. You will have to redo all settings from scratch but it could be the solution.

Marc

Ok, Thanks for all the help! I truly appreciate it!
I’ll re-install the image and redo everything tonight then.

In the mean time, would you mind helping me with this: Throttle mid too low ?
I checked my mid throttle is 27%, but didn’t find the parameter I should change in order to adjust it to the system.

The parameter is MOT_THST_HOVER

And your Rcout graph should look like this one, with RCout trace like a large fuzzy line, not changing from minimum to max.

RCout

Marc

Hey there!

I updated my system to the newest image. My RC outputs look much nicer:

I was able to takeoff even on Alt Hold and Loiter. The problem with both these flight mode was: They go up, act for a few seconds as they are supposed to, and then start slowly going down, forcing me to keep increasing the throttle stick. I saw the log and noticed that the motors outputs are saturating:


2017-12-01 21-09-45.bin (2.6 MB)

They should follow the red input line, right?

One other thought that came to mind as well was that maybe the problem was with the readings of the sensor. Since my problem is it loses height, then maybe my height sensor (aka barometer) could be giving my system the wrong readings. So I checked the altitude log values:

This graph seemed weird to me because it seems that the readings show the drone kept increasing its height during all flight time. If that’s the case, it’s totally incorrect because during this log I took off and landed several times.

Is my analysis correct? What can I try to adjust so it stays at the height level it is supposed to?

Thanks!

Hello,

Your barometer data is not good. There is a problem with It. It should not increase that way along the flight.

RCout follow Rc3in when flying stabilise mode and it is correct. No problem there.

Marc

How do I fix the barometer? I already have it covered by a foam:


Also, I have a general-purpose uart sonar here with me:

How simple is it to add it to the system and switch the UAV’s height readings from the barometer to the sonar?

Thanks!

Hello,

You need soft open foam (like sponge). You do not want to close the vent of the barometer, just protect it from external perturbations like air flow and light.

Marc

Worked like a charm.

Thanks!