AHRS issues

Hi all - a little light on the following conundrum would be appreciated!

I’m having some trouble with AHRS on my Navio2 - it seems that when I rotate the board in pitch, it also senses a roll.

I dug around in the docs and was in the process of investigating using the AHRS C++ example, I have the python ‘floating brick’ rendering on my pc, however I get a segmentation faults when I run the example code on the Pi.

Update - a significantly more careful calibration seems to have fixed the first issue. I strapped a spirit-level to the frame and used that to get things accurate. Either it helped, or re-calibrating a few times did - either way!

Still no floating brick though - assume it’s in the pipeline with the port fro navio+?

The floating brick is meant to be run on the PC, not on the Pi. If you could provide more info about what is crashing and how we might be able to help you.

Thanks @ivereninov,

I am running 3Dimu.py on a pc.

I installed Python 2.7 (new PC) and then pip,
then ran:

pip install PyOpenGL PyOpenGL_accelerate pip install pyserial python 3Dimu.py

I get a single line of output:

Segmentation Fault

Segmentation fault usually caused due to some kind of memory problem. Caused by a program trying to read or write an illegal memory location.

Might it because because I had to use a binary to install PyOpenGL

Possibly. Python is a bit funny on windows it tends to require a bit more to set up and sometimes the libraries dont work. Try uninstalling opengl from python and then using easy_install opengl instead.

1 Like

ah-ha! easy_install made the magic happen for me. Thanks!