Emlid

Community Forum

Agribus Navi problem


(Mmormota Mmormota) #1

Hi,
I am about to use Emlid Reach RS+ Base-Rover configuration with Agribus Navi. The Base-Rover RTK is working, gets FIX, connects well to either the Emlid Android app or to a Windows PC browser using wifi tcp. The connection between the Base and Rover is Lora.

My problem:

  1. If I set bluetooth connection on the Rover and Agribus (on an Android tablet or a mobilphone), it works but the connection is unreliable, it flickers between no gnss and gps fix. Checking Emlid with another phone on wifi, the RTK Fix is stable, just the Bluetooth connection is faulty.

  2. Because of the Bluetooth problem, I switched to wifi tcp on both sides. Unfortunately it is not working with Agribus at all.
    Details:

  • the tablet is connected on wifi to Emlid Reach RS+
  • if I start a browser on the tablet, and set the address to 192.168.42.1. it works, starts the Emlid program
  • in Emlid, one of the outputs set to tcp, port 9001, NMEA
  • not sure if server or client is the proper setting on the Rover, but none working
  • in the Agribus navi, connection set to tcp, port 9001, NMEA, nor localhost, nor the above 192.168.42.1. ip address is working

Please, help me, how to set properly the tcp connection, or make stable Bluetooth connection.


#3

I don’t know if it is related, but I have heard of an issue where certain devices expect a specific NMEA message(s). So if Reach outputs more than that message, the device won’t recognize those extra messages. Further, the device will report loss of fix until the next recognized message comes.

The result is a flickering FIX status which changes for each message received depending on whether the message is a recognized one or not.

I am speaking in generalities here because I don’t truly know the detail of the problem, but it was something like that.

So, for this case it might have looked like the connection was breaking repeatedly, but in fact the connection was fine.


(Tatiana Andreeva) #4

Hi @mmormota2,

I tried to output coordinates from Reach to this app, however, I wasn’t able to reproduce the issue with BT.

May I ask you to swap Reach base and rover and test it again?


(Mmormota Mmormota) #5

Thank you both the informative reply.

Tatiana: I will test it.

Could you please try to connect the app using wifi tcp as well? If wifi tcp is working, please give me a short tutorial how to setup that. I tried hard, but all my efforts failed…


(Tatiana Andreeva) #6

Hi @mmormota2,

Sorry for the delayed reply!

I’ll try that and write back to you.

Have you already tested it?