Access Reach over Public IP

I am trying to access my RS2+ over a public static IP but I am having problems.
I can access the web interface from my phone using chrome browser, but I cannot access it from my desktop. I have tried chrome, firefox and microsoft edge. The browser tab shows “Reach Panel” but the screen is blank.


Hi Anthony,

To connect to the Reach device, you need to be connected to the same network. For example, if your Reach is in hotspot mode, you need to connect to its hotspot (reach:XX:XX.). Can you double-check that you’re connected?

If there’s still an issue, please share the screenshot of what you see in the browser.


The receiver is set up at a remote location, that is why I have a static public IP address. I have another RS2+ setup at a remote location that I attached a cellular modem/router to that I can access from my desktop.

1 Like

From reading previous posts having Verizon as the service provider may not work. I will change it to at&t and see if that works better


Yes, there are some restrictions from the Verizon side. For the USA, you can check out other SIM card providers that worked for our users: EIOTCLUB/Twilio/SPECTRUM SIM cards. Please note that for AT&T, we suggest checking the data+voice plan.

Let me know how it goes!