AccelGyroMag Error: Can not open SPI device

Trying to run the example ./AccelGyroMag I got this error, any ideas?

Did you sudo the command?
if you run lsmod are spi_bcm2708 and spidev showing? do /dev/spidev0.0 and /dev/spidev0.1 exist?

Thanks. It was the sudo… :frowning:

Working perfectly now, thanks again.

I only get 0 output for all readings, too. It used to look like netxingnets problem (“Cannot open SPI device”). Then I tried it with sudo and ever since the only output for all 9 readings is 8. so I tried lsmod and there’s no spidev. how can I add that? I already installed the latest RTK from this page.
Thanks for your input.


Marco, could you please post the terminal output when running AccelGyroMag?

damn that was quick. thanks for that.
hope the quality is good enough.

@marcopfahler Do any other sensors on the board work? If so, this is clearly a MPU9250 failure and your board will be replaced.

temperature and pressure work fine and i havent tried GPS yet since I didnt buy an antenna so far.

@marcopfahler I have sent you an email with information about return. Sorry about the inconvenience.