A6000 hot shoe issue?

Went out today to try the Reach M+ for PPK for the first time. No shutter events were logged. I found out that the built-in flash of the A6000 needs to be extended. Weird stuff. It doesn’t capture shutter times when it’s folded down. What do I need to change in the settings to make this work when it’s folded down? Other than it’s just silly that it only works like this, my gimbal doesn’t have room for the extended built-in flasher. Other option is to remove the flasher somehow…

Hi @jantjj,

We’ve got a lot of users with A6000 camera and it’s not a common issue.

Why do you think that flash needs to be extended? What shooting mode do you use?
Also, can you share your setup photos, please?

It needs to be extended, because otherwise no shutter events are being logged, apparently. When I close it: no event log. When I open it: event log.

For shooting mode I use full manual settings, except ISO… so manual focus, manual aperture and manual shutter speed. I use the time lapse app on the A6000 to shoot a picture every x seconds, depending on what I need, so it’s not being triggered by the Reach M+ or by the flight controller. Shouldn’t matter though.

No fix?

Does the a6000 have a PC sync plug?

Maybe this user could share some info about the settings on the camera?

Hi @jantjj

Maybe it is the problem connected with the time-lapse app?
Are there any time marks in RechView when making photos manually without flash and the app?

Also, can you share your setup photos and camera firmware version, please, so that we can compare it with ours?

I’ll check this for you tomorrow @andrew.yushkevich. Busy now. But I don’t think it’s related to the time lapse app, as it won’t log shutter events when pushing the button on the camera either (without the time lapse app, when the flashlight isn’t extended).

@TB_RTK… regarding that quote you posted. Static mode setting on the Reach when flying? I don’t get it. And why would you need float or fix for PPK? Am I totally missing something? I thought I had this PPK thing down… :confused:

I was thinking of camera and if there is a setting on the A6000 that triggers or not the hotshoe mechanism.
But sounds like @andrew.yushkevich has the same modell and could share it as well :slight_smile:

@andrew.yushkevich
As requested :wink:

Hi @jantjj,

I’ve made a test with A6000 in manual mode with the same settings you’ve written.
I’ve no problems with getting timestamps. With extended flash timestamps works too.

Hope to see your test result as well to find the reason.

Thanks.

Hey folks, I am still using the first generation of Reach module and haven’t had time to try the M+ yet. The below are what I did to have the time stamp work perfectly on my original Reach module:

1: Use the sand paper to sand the inner side of the A6000 hot shoe. The black A6000 has a layer of blacking coating on the hot shoe which prevent connection with your adapter.

2: Following the link to setup the signal source based on the table from efedorov:


I am using GPS+SBAS+QZSS and it worked pretty good and final ppk result is great.

That is all I did to make the A6000 working with Reach module.
Thanks.

2 Likes

Thanks! Please take a look at the picture of my A6000… what do I need to sand?

Check the below youtube video and it explain clearly. It is easy to sand.

Fixed! Thanks a lot @air.looker! Sanding the inside of the hotshoe did the trick :slight_smile: Reach logs fine now, also with the timelapse app!

3 Likes