A few issues with my first navio project

Hi guys!

It’s my first post here, but I’ve spent a lot of hours reading other posts :smile: I can fly my drone but now I’m trying to resolve the final problems, I was following the guides or topics here but I didn’t solve my problem with that. In resume my problems are:

1.- Auto Boot; I have more or less this problem:[APM does not autostart on boot][1] but if I do that I can’t stop the process(ctrl+c doesn’t work) because using & the program is not in the background, I use in /etc/rc.local :
sudo ArduCopter-quad -C /dev/ttyAMA0 &
if I use & to start the ArduCopter the programa doesn’t start… (could I have a background problem?)

I start the program with sudo ArduCopter-quad -C /dev/ttyAMA0 without problems, only that is not in background and the commads that I see in the console are not understandable

2.- Failsafe doesnt work as its has to work; In mission planner following [http://copter.ardupilot.com/wiki/throttle-failsafe/][2] if I use in mission planner “Enable always LAND” with RC fail, testing if I turn off my RC the system remember the position of my sticks

3.- GPS no Fix; I think that is a power problem because I see more the problem when I connect the motors or I use the battery(with usb and without motors normally works but no always). The problem is that some times in mission planner when I connect I have: GPS no Fix (only some times)

And in extra, is not a problem only a doubt, can I start to fly without GCS? I have always to start in mission planner and click in armed… :sweat_smile:

Thanks for your time! and sorry for so many questions :blush:
[1]: APM does not autostart on boot
[2]: http://copter.ardupilot.com/wiki/throttle-failsafe/


  1. To stop any process running in the backround, you can use “sudo killall ‘processname’”. In your case replace processname with ArduCopter-quad.

  2. You have to configure your RC receiver to send no pulses or low throttle, if the connection to the transmitter is lost.
    Default failsafe setting for most RC systems is to hold the last received input. APM has no means to notice a failsafe with this setting.

Hi Victor, welcome to the forum!

  1. Where are you testing the GPS? Is that a place with an open sky view?

  2. You can arm\disarm APM without the GCS using throttle and ruder channels like explained here:

Thanks Sebastian for remind me the sudo killall was usefull.

Problems 1 and 2 are solved, in 1 I had to create a .sh with the commands in /home/pi and exec that in crontab with crontab -e.
In .sh file:
sudo ArduCopter-quad -C /dev/ttyAMA0 &
screen -U
***screen -U to resolve UTF-8 problem

, and in the point 2 I found in my TX the correct config.

mikhailavkhimenia Im using inside but just in the window, I didnt have problem when I started to connect parts, worked always, I’ll try outside first of all…

Now I only need out armed the drone with GCS. http://copter.ardupilot.com/wiki/arming_the_motors/ doesnt work, I think that is other TX config Problem, I move the stick like the guide but doesnt start.

But finally I have a big problem, 1 of the rotors doesnt work fine, I have to give back… I’ll follow with the tests when I’ll receive the new rotor… :sweat:

Thanks and I hope come back for here soon

Hello Victor,

You shouldn’t use sudo while configuring system scripts which are already run by root, like rc.local. The comand sudo is useful when you are connected as a regular user, to temporarily climb rights, ant it often asks for a password which may be inconvenient in automated procedures. The same goes for cron, as one can configure a crontab per user.

Like you, I created a script (without sudo) which is executed at startup with rc.local. This script should have read and execute rights (chmod a+rx script.sh to do that). Ampersand is useful in rc.local but rarely in other scripts or cron tasks as there is nothing to detach.

If you need screen to resolve encoding problems, it may mean that your locales are badly configured. You can use raspi-config to set UTF-8 as your standard locale. if you type echo $LANG it will show your locale.

For failsafe, have you also configured a RTL button on your radio with Channels 7 or 8 ? It is quite simple in Mission Planner.

For your GPS, I’m no expert but inaccuracy may be caused by interferences with other electronic devices like raspicam. I’m not sure about that but I think GPS fix problems depend on the flight mode which doesn’t always use GPS, and also on other parameters that I did not clearly identified.

Most of my post isn’t RC-related but I hope it helps !


GPS won’t work properly near the window as satellites will get out of the view from time to time (which looks like your situtation).

If you can arm APM in Mission Planner then you should be able to arm it with rudder channel. Strange that it doesn’t work for you, do you have any channels remapped?