3dr radio communication issue


I’m having some trouble to send correction input from base to rover using 3dr radio, although it is working fine if I use TCP (i.e. gray bars are shown and fixed solution is computed).
Here is my setup:

  • ground radio telemtry with 433 MHz is connected to emlid reach via usb otg
  • emlid board itself is connected to navio2 which is power by external battery


As I mentioned before TCP communication between base and rover works fine.
In order to communicate via radio telemetry I set Base Mode to the following settings

  • ground radio telemetry status led is blinking red ( which means transmitting data) and solid green (which means link established) [according to https://3dr.com/wp-content/uploads/2013/10/3DR-Radio-V2-doc1.pdf]
  • I tried different baud rates (57600 and 115200) but none of them is working
  • Position Output and Correction Input are turned off

Settings for Rover looks the following:

  • air radio telemetry status led is solid green as well
  • Base Mode and Position Output are turned off

For me it looks like base is sending correction data but it is somehow no properly recieved by the rover.
ReachView version is up to date v2.11.0.

Many thanks in advance for your help.

I think it is your wiring. On the receiver I see the red wire going to TX on the Modem and +5V on the reach.

It’s a while but I remember I needed to change some wires with these cheap USB modules. There is a section in the docs where you can see the Pin-Out of the reach module. The Wiring on your Modem is stated on the plastic case.
Try to swap the green and the red wire…



Sorry for the late answer. In case you have not be able to work through this, here’s some tips:

I think you need to check the radios by themselves first. You can connect them to a computer and send some data using a terminal emulator. Most likely, one of these two issues prevents communication:

  • Incorrect wiring
  • Radios’ internal baud rate is different from the one you set in ReachView. Radios need to be configured to the same baud rate as the Reach units.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.