3dr modules for reach


I`ve succesfully completed the quickstart guide and I get green and grey bars if I send the rtcm3 data via network.
After that I tried to hook up 3dr 433mhz modules. I used the default configurations, 57600 baud serial i/o for the modules and I connected vcc, gnd, and tx/rx for base/rover and changed to serial communication in the reach app (the manual is rather unclear how to do that exactly):

No luck here, I got only “single” mode. I tried to wire the serial cables directly together to rule out a fault in the 3dr modules (blue-green for base-rover & gnd) but still nothing. I also tried to read out some serial data with a uart to usb module and the Arduino serial monitor (which I used to test the nmea output of the rover on the tx line) but at 57600 baud I get only garbage.

Some help or ideas would be great!
Thanks and regards

I was able to get this working with the same configuration you show. Do your 3dr modules show solid green leds with a blinking red (indicating data transfer)?

Yes, they did so I think they should work. They also worked on the APM the day before.
And even if I hardwire the serial connection I get no “fix/float”.

I think the next thing I`m going to try is reflashing the firmware to reset and restart everything.


Before reflashing, do grey bars appear on the rover behind the satellite signal strength bars?

They did when I connected them via wireless network. Serial didn`t work at all.

Have you crossed rx/tx?

Yes, blue (tx) on the base with green (rx) on the rover & gnd.

I tried to reflash the modules to reset them now. I used the Phone Flash Tool and the current .json file. The program exited succesfull. I then did the wireless setup and I can see the devices as 192…86 and 192…246 in my network and I can reach them via ssh and even log in via ssh. Also the IP at port 5000 reports the device name and the ip, all good so far.

The only problem is that the app doesnt work at all now. Windows, phone, it doesnt matter I do not get to the app view!!!

So after a very long time I can acces both modules again. However, for some reason now it only works when I use my phones hotspot. The reflashing, reconecting, updating and setup process took several attempts to work. All in all the app is exactly what it says, v0.0.1, so you guys from emlid have a lot to do in the next weeks…

Serial is still not working thought. Does sombody have the frame specs for the rtcm3 output signal so that I can have a look there. Because whatever it is, it`s not the Arduino standart (8 data bits, 1 stop bit, no parity bit).


Thats all I get from the base tx port. Would be great if you could give me the correct serial frame settings so I can check whats actually comming out there. Thanks.

Now it works, grey bars and “fix” status! Great!

The error was that I trusted your picture in the wiki in “hardware integration” where the cable color of the rx lines is shown as green instead of withe!!!
I fixed it on github because that was about the last thing I was going to check. The blue color for the TX line is fine which makes it even more confusing since I was getting some signal there.

Igor: I would still be intrested in the correct serial frame settings for the rtcm3 protocol. Thanks!

Good! Really glad that you got it working!

The picture was not meant to show real colors of the wires, but I understand the confusion. We will improve that.

I am not sure what you expect to see there, RTCM3 is a binary format, so it is not human readable. If you are getting RTK FIX, that means that it goes through just fine.

And we will :smile: Your feedback is really appreciated, we are working hard to adress all the issues. Thank you for supporting Reach, for your patience and detailed reports!

I expected somthing along the line of the nmea format. But thats nice to know, that explains why the “char” decoding doesn`t work.

Great to hear! Thank you very much for your replays as well!!!

hi, i want buy reach and 3dr modules? which modules do you use? did you test wich distances to modules can work? how much kilometers?


I have original 3dr v1 433mhz and jDrone 868mhz modules. Which one you want depends on the country in which you want to use them. The RF module is the same for all the available options I have seen.

The reach depends somewhat on data rate and is slightly better on the 433mhz modules. But the most important are high quality antennas!

I went maybe 5km out with 433mhz @ 100mW on the included whip-antennas and then 10km+ @ 10mW with diy 1/4 lamda dipole and a yagi, mounted on a pole (ground) and far from all the electronics (copter).

Ok. I want use it for agriculture and want Mount it in my Silo 15 m obove Grund and on my Trecker…

Is it possible to install a little rtk network with 3 to 4 base stations and many Rovers?

Should be no problem, depending on how you want to send your correction data from the base to the rover.

The base is broadcasting all the rover modules in its 10km radius exactly the same data. Im not sure, however, if you can eg. use a 3dr 433mhz module as transmitter with multiple slave units.

Good morning Andreas

Could you please send me a datailed picture about cable connection, because, I could not connect my 3DR radios. I think the problem is the order of cables.

On the other hand, could you send us a preview of you configuration on ReachViewApp (Base and Rover).

Thanks in advanced.

Regarding this, Reach comes with two sets of UART wires. One is straight pass-thru and the other has each lead independent. I’m guessing that the straight pass-thru cable will not work with these 3DR radios since Tx/Rx are swapped? What is that cable for then?

It is for connection to Pixhawk/Navio.