Update to firmware 2.25.1 not successful

I tried updating to reachview 2.25 1 from stable reachview 2 24 but after complete download and rebooting the firmware reverts to the old one.

I wonder why. So I guess I will just continue using what I have.


My other receiver is not shuting down all 3 lights are continuing to flush

Also me for two days

I managed to complete the update on one of my receivers by shutting down the receiver after the download instead of rebooting from the reachview app or browser.

Am yet to update firmware on the other receiver - which is not connecting to the hotspot wifi from my laptop or from my smartphone. Will have to drive far away where there possibly wl be no wifi nearby that the receiver might be connecting to

Hi Mohamed and Petros,

Usually, the issues with the updating process are caused by the unstable Internet connection. Please try moving your receiver closer to the Wi-Fi router. If that doesn’t help, please, check with another Wi-Fi network.


Please, share the video of the LED status and the serial number of the device with us via support@emlid.com. You can find the serial number on the bottom side of the unit under the bar code.

Hi Petros, Mohamed,

How is it going? Could you clarify what receiver model you use?

Please email us on support@emlid.com with the Full system reports and the serial number and LED status video, as Polina said before. You can download the Full system report in the ReachView Settings tab.

I was able to update my M+ and one of my RS2 units to 2.25.1 with no issues. But the second RS2 unit would not update after many attempts. It kept showing the script lines instead of actually loading the page to do the update. I made sure that Mobile Data was turned off because the SIM needs to be renewed. But that did not solve the problem.

So I had to flash the latest Stable firmware and then it updated to the 2.25.1 beta. The problem I had was that the script was showing on the screen instead of actually running. I still need to update my M2 so I will see how that goes.

Hi. Sorry for the delay in responding. I eventually managed to switch it off. Only I haven’t managed to update it as it wasn’t connecting to my wifi. Wil try updating it this weekend

Thanks am using Reach RS+ and all is now ok. Sorry for the late update. Both receivers have also been updated to 2.25.1. The last update for the second receiver was done using a wifi hotspot from another smartphone

The flashing stopped after I tried once again for sometime and it switched off. Now they are both working without issues.

Hi Tim,

Would you mind sharing the screenshot showing the issue?

Hi Petros,

I got you. Please let me know if you face any other difficulties.

Am having an issue with one of my RS+'s not rebooting after the update from 2.24 to dev 2.25 appeared to have completed successfully. The rover was already on dev and updated just fine. The base was a replacement that I was sent that sat in the box for the last 4 months. When it booted I had to do the initial setup and update to 2.24 before I could get into settings. Once 2.24 installed correctly I was able to enroll the dev and was prompted to update to 2.25. I tried two different sources of WiFi and it appeared to have completed both times and requested the reboot, but both times it did not and when I manually boot it the setting still show it on 2.24 and requesting the 2.25 update.

The reboot command from the settings menu in Reachview 2 works just fine.

The 4th attempt on a mobile hotspot driving around worked, LOL!

Hi Michael,

We had a similar report, and we’re already looking into this issue. I’ll write you back as soon as there is any news.

1 Like

Hi there,

Just want to let you know that we’ve found the cause of this issue. We’re already working on a fix. I’ll notify you once it’s released.


Great news :smiley:

Hi guys,

We’ve just released the dev v2.25.2. The issues with the updating process should be resolved.

Please check the list of all fixes and improvements in this post.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.